5500 C++ Programming Manual: D:/5500/Cpp Directory Reference

5500 C++ Programming Manual
Cpp Directory Reference

Files

file JY5500.h
@SectionBegin JY5500 FileHead
Generated by doxygen 1.9.1


5500 C++ Programming Manual: D:/5500/Cpp/JY5500.h File Reference

Typedefs | Enumerations | Functions
JY5500.h File Reference

@SectionBegin JY5500 FileHead More...

Typedefs

typedef void * JY5500_DeviceHandle
@SectionEnd JY5500_Device FileHead More...

Enumerations

enum | JY5500_ReferenceClock { JY5500_Internal = 0x0 , JY5500_PXIe_Clk100 = 0x1 }
enum | JY5500_AI_SampleMode { JY5500_AI_Finite = 0x0 , JY5500_AI_Continuous = 0x1 , JY5500_AI_Single = 0x2 }
enum | JY5500_AI_Terminal { JY5500_AI_RSE = 0x0 , JY5500_AI_NRSE = 0x1 , JY5500_AI_Diff = 0x2 }
enum | JY5500_AO_UpdateMode { JY5500_AO_Finite = 0x0 , JY5500_AO_ContinuousWrapping = 0x1 , JY5500_AO_ContinuousNoWrapping = 0x2 , JY5500_AO_Single = 0x3 }
enum | JY5500_DI_SampleMode { JY5500_DI_Finite = 0x0 , JY5500_DI_Continuous = 0x1 , JY5500_DI_Single = 0x2 }
enum | JY5500_DO_UpdateMode { JY5500_DO_Finite = 0x0 , JY5500_DO_ContinuousWrapping = 0x1 , JY5500_DO_ContinuousNoWrapping = 0x2 , JY5500_DO_Single = 0x3 }
enum | JY5500_CI_SampleMode { JY5500_CI_Finite = 0x0 , JY5500_CI_Continuous = 0x1 , JY5500_CI_Single = 0x2 }
enum | JY5500_CO_OUTMode { JY5500_CO_Finite = 0x0 , JY5500_CO_ContinuousWrapping = 0x1 , JY5500_CO_ContinuousNoWrapping = 0x2 , JY5500_CO_Single = 0x3 }
enum | JY5500_TriggerMode { JY5500_StartTrigger = 0x0 , JY5500_ReferenceTrigger = 0x1 }
enum | JY5500_AI_TriggerType { JY5500_AI_Immediately = 0x0 , JY5500_AI_Digital = 0x1 , JY5500_AI_Analog = 0x2 , JY5500_AI_Soft = 0x3 }
enum | JY5500_AO_TriggerType { JY5500_AO_Immediately = 0x0 , JY5500_AO_Digital = 0x1 , JY5500_AO_Soft = 0x3 }
enum | JY5500_DI_TriggerType { JY5500_DI_Immediately = 0x0 , JY5500_DI_Digital = 0x1 , JY5500_DI_Soft = 0x3 }
enum | JY5500_DO_TriggerType { JY5500_DO_Immediately = 0x0 , JY5500_DO_Digital = 0x1 , JY5500_DO_Soft = 0x3 }
enum | JY5500_CIO_TriggerType { JY5500_CIO_Immediately = 0x0 , JY5500_CIO_Digital = 0x1 , JY5500_CIO_Soft = 0x3 }
enum | JY5500_DigitalTriggerEdge { JY5500_Rising = 0x0 , JY5500_Falling = 0x1 }
enum JY5500_DigitalTriggerSource {
JY5500_PFI0 = 0x0 , JY5500_PFI1 = 0x1 , JY5500_PFI2 = 0x2 , JY5500_PFI3 = 0x3 ,
JY5500_PFI4 = 0x4 , JY5500_PFI5 = 0x5 , JY5500_PFI6 = 0x6 , JY5500_PFI7 = 0x7 ,
JY5500_PFI8 = 0x8 , JY5500_PFI9 = 0x9 , JY5500_PFI10 = 0xA , JY5500_PFI11 = 0xB ,
JY5500_PFI12 = 0xC , JY5500_PFI13 = 0xD , JY5500_PFI14 = 0xE , JY5500_PFI15 = 0xF ,
JY5500_Inter_AI_StartTrig = 16 , JY5500_Inter_AI_ReferenceTrig = 17 , JY5500_Inter_DI_StartTrig = 22 , JY5500_Inter_DI_ReferenceTrig = 23 ,
JY5500_Inter_AO_StartTrig = 26 , JY5500_Inter_DO_StartTrig = 29 , JY5500_Inter_CI_0_StartTrig = 68 , JY5500_Inter_CI_1_StartTrig = 73 ,
JY5500_Inter_CI_2_StartTrig = 76 , JY5500_Inter_CI_3_StartTrig = 79 , JY5500_Inter_CO_0_StartTrig = 69 , JY5500_Inter_CO_1_StartTrig = 74 ,
JY5500_Inter_CO_2_StartTrig = 77 , JY5500_Inter_CO_3_StartTrig = 80 , JY5500_Inter_CO_0_Output_Trig = 37 , JY5500_Inter_CO_1_Output_Trig = 51 ,
JY5500_Inter_CO_2_Output_Trig = 60 , JY5500_Inter_CO_3_Output_Trig = 66 , JY5500_PXI_Trig0 = 40 , JY5500_PXI_Trig1 = 41 ,
JY5500_PXI_Trig2 = 42 , JY5500_PXI_Trig3 = 43 , JY5500_PXI_Trig4 = 44 , JY5500_PXI_Trig5 = 45 ,
JY5500_PXI_Trig6 = 46 , JY5500_PXI_Trig7 = 47
}
enum JY5500_AnalogTriggerSource {
JY5500_Channel_0 = 0 , JY5500_Channel_1 = 1 , JY5500_Channel_2 = 2 , JY5500_Channel_3 = 3 ,
JY5500_Channel_4 = 4 , JY5500_Channel_5 = 5 , JY5500_Channel_6 = 6 , JY5500_Channel_7 = 7 ,
JY5500_Channel_8 = 8 , JY5500_Channel_9 = 9 , JY5500_Channel_10 = 10 , JY5500_Channel_11 = 11 ,
JY5500_Channel_12 = 12 , JY5500_Channel_13 = 13 , JY5500_Channel_14 = 14 , JY5500_Channel_15 = 15 ,
JY5500_Channel_16 = 16 , JY5500_Channel_17 = 17 , JY5500_Channel_18 = 18 , JY5500_Channel_19 = 19 ,
JY5500_Channel_20 = 20 , JY5500_Channel_21 = 21 , JY5500_Channel_22 = 22 , JY5500_Channel_23 = 23 ,
JY5500_Channel_24 = 24 , JY5500_Channel_25 = 25 , JY5500_Channel_26 = 26 , JY5500_Channel_27 = 27 ,
JY5500_Channel_28 = 28 , JY5500_Channel_29 = 29 , JY5500_Channel_30 = 30 , JY5500_Channel_31 = 31
}
enum | JY5500_AnalogWindowCondition { JY5500_Entering = 0x0 , JY5500_Leaving = 0x1 }
enum | JY5500_AnalogTriggerEdge { JY5500_RisingSlope = 0x0 , JY5500_FallingSlope = 0x1 }
enum | JY5500_ClockSource { JY5500_InternalClock = 0x0 , JY5500_ExternalClock = 0x1 }
enum JY5500_ExternalClockTerminal {
JY5500_ECLK = 0 , JY5500_Inter_AI_SampleClock = 20 , JY5500_Inter_AO_SampleClock = 28 , JY5500_Inter_DI_SampleClock = 53 ,
JY5500_Inter_DO_SampleClock = 54 , JY5500_Inter_CI0_SampleClock = 36 , JY5500_Inter_CI1_SampleClock = 50 , JY5500_Inter_CI2_SampleClock = 59 ,
JY5500_Inter_CI3_SampleClock = 65 , JY5500_Inter_CO_0_Output = 37 , JY5500_Inter_CO_1_Output = 51 , JY5500_Inter_CO_2_Output = 60 ,
JY5500_Inter_CO_3_Output = 66 , JY5500_PXI_Trig0_IN = 40 , JY5500_PXI_Trig1_IN = 41 , JY5500_PXI_Trig2_IN = 42 ,
JY5500_PXI_Trig3_IN = 43 , JY5500_PXI_Trig4_IN = 44 , JY5500_PXI_Trig5_IN = 45 , JY5500_PXI_Trig6_IN = 46 ,
JY5500_PXI_Trig7_IN = 47
}
enum | JY5500_CountTimeBase { JY5500_TimeBase_200M }
enum | JY5500_CountDirection { JY5500_CI_Count_Up , JY5500_CI_Count_Down , JY5500_CI_Count_External }
enum JY5500_CI_MeasureType {
JY5500_CI_EdgeCount = 0 , JY5500_CI_Measure_FrequencyOrPeriod = 1 , JY5500_CI_Measure_PulseWidth = 2 , JY5500_CI_Measure_EdgeSeparation = 3 ,
JY5500_CI_EncoderX1 =4 , JY5500_CI_EncoderX2 = 5 , JY5500_CI_EncoderX4 = 6 , JY5500_CI_EncoderTwoPulse = 7
}
enum | JY5500_CI_SampleClock { JY5500_CI_ImplicitClock , JY5500_CI_InternalClock , JY5500_CI_ExternalClock }
enum | JY5500_CI_CounterEventSignalIdleState { JY5500_CI_CounterEventSignalIdleState_Low = 0 , JY5500_CI_CounterEventSignalIdleState_High = 1 }
CI Counter Event Signal Idle State. More...
enum | JY5500_LevelState { JY5500_LowLevel = 0 , JY5500_HighLevel = 1 }
enum | JY5500_CO_IdleState { JY5500_CO_LowLevel = 0 , JY5500_CO_HighLevel = 1 }
enum JY5500_Signal_Source {
JY5500_AI_StartTrig = 16 , JY5500_AI_ReferenceTrig = 17 , JY5500_DI_StartTrig = 22 , JY5500_DI_ReferenceTrig = 23 ,
JY5500_AO_StartTrig = 26 , JY5500_DO_StartTrig = 29 , JY5500_CI_0_StartTrig = 68 , JY5500_CI_1_StartTrig = 73 ,
JY5500_CI_2_StartTrig = 76 , JY5500_CI_3_StartTrig = 79 , JY5500_CO_0_StartTrig = 69 , JY5500_CO_1_StartTrig = 74 ,
JY5500_CO_2_StartTrig = 77 , JY5500_CO_3_StartTrig = 80 , JY5500_AI_SampleClock = 20 , JY5500_AO_SampleClock = 28 ,
JY5500_DI_SampleClock = 53 , JY5500_DO_SampleClock = 54 , JY5500_CI_0_SampleClock = 36 , JY5500_CI_1_SampleClock = 50 ,
JY5500_CI_2_SampleClock = 59 , JY5500_CI_3_SampleClock = 65 , JY5500_CO_0_Output = 37 , JY5500_CO_1_Output = 51 ,
JY5500_CO_2_Output = 60 , JY5500_CO_3_Output = 66
}
enum JY5500_Signal_Destination {
JY5500_PFI0_OUT = 0x0 , JY5500_PFI1_OUT = 0x1 , JY5500_PFI2_OUT = 0x2 , JY5500_PFI3_OUT = 0x3 ,
JY5500_PFI4_OUT = 0x4 , JY5500_PFI5_OUT = 0x5 , JY5500_PFI6_OUT = 0x6 , JY5500_PFI7_OUT = 0x7 ,
JY5500_PFI8_OUT = 0x8 , JY5500_PFI9_OUT = 0x9 , JY5500_PFI10_OUT = 0xA , JY5500_PFI11_OUT = 0xB ,
JY5500_PFI12_OUT = 0xC , JY5500_PFI13_OUT = 0xD , JY5500_PFI14_OUT = 0xE , JY5500_PFI15_OUT = 0xF ,
JY5500_PXITrig0_OUT = 0x20 , JY5500_PXITrig1_OUT = 0x21 , JY5500_PXITrig2_OUT = 0x22 , JY5500_PXITrig3_OUT = 0x23 ,
JY5500_PXITrig4_OUT = 0x24 , JY5500_PXITrig5_OUT = 0x25 , JY5500_PXITrig6_OUT = 0x26 , JY5500_PXITrig7_OUT = 0x27
}
enum | JY5500_PowerLineFrequency { JY5500_50_Hz , JY5500_60_Hz }

Functions

JY5500API int | JY5500_Open (int slotNumber, JY5500_DeviceHandle *hDevice)
Open the 5500 series devices using the slot number or the device serial number. More...
JY5500API int | JY5500_OpenByName (const char *cardName, JY5500_DeviceHandle *hDevice)
Open this 5500 series devices using the device alias name which is set by JYTEK utility JYDM. More...
JY5500API int | JY5500_GetDeviceID (JY5500_DeviceHandle hDevice, int *deviceID)
Obtain the device ID. More...
JY5500API int | JY5500_GetDeviceSerialNumber (JY5500_DeviceHandle hDevice, char *serialNumber, int length)
Obtain the device serialNumber More...
JY5500API int | JY5500_SetDeviceStatusLed (JY5500_DeviceHandle hDevice, bool enable, unsigned int frequency)
Control Front Panel Status Led More...
JY5500API int | JY5500_Close (JY5500_DeviceHandle hDevice)
Close this 5500 device. More...
JY5500API int | JY5500_SignalRouting (JY5500_DeviceHandle hDevice, JY5500_Signal_Source source, JY5500_Signal_Destination destination)
Route a singal from source to destination. More...
JY5500API int | JY5500_DisconnectSignalRouting (JY5500_DeviceHandle hDevice, JY5500_Signal_Destination destination)
Disconnect an established routing. More...
JY5500API int | JY5500_SetDeviceReferenceClock (JY5500_DeviceHandle hDevice, JY5500_ReferenceClock clkSource)
Set ReferenceClock for the device.There are two ReferenceClock, Internal 25MHz from this device or 100MHz from the PXIe chassis. More...
JY5500API int | JY5500_GetDeviceFPGATemperature (JY5500_DeviceHandle hDevice, double *temperature)
Get FPGA temperature reading of the device in Celsius degree. More...
JY5500API int | JY5500_GetDeviceTemperature (JY5500_DeviceHandle hDevice, double *temperature)
Get Device temperature reading of the device in Celsius degree. More...
JY5500API int | JY5500_AI_EnableChannel (JY5500_DeviceHandle hDevice, unsigned int channelCount, unsigned char *channels, double *lowRegion, double *highRegion, JY5500_AI_Terminal *terminal)
Enable AI channels. More...
JY5500API int | JY5500_AI_SetMode (JY5500_DeviceHandle hDevice, JY5500_AI_SampleMode mode)
Set AI sampling mode More...
JY5500API int | JY5500_AI_SetSampleRate (JY5500_DeviceHandle hDevice, double sampleRate, double *actualSampleRate)
Set sampling rate. More...
JY5500API int | JY5500_AI_SetConvertRate (JY5500_DeviceHandle hDevice, double convertRate, double *actualConvertRate)
Set convert rate. More...
JY5500API int | JY5500_AI_SetSamplesToAcquire (JY5500_DeviceHandle hDevice, unsigned int sampleToAcquire)
Set AI samples to acquire for each channel in finite mode.The samples range is 1 to 64M samples / channelCount. More...
JY5500API int | JY5500_AI_Start (JY5500_DeviceHandle hDevice)
Start AI acquisition. More...
JY5500API int | JY5500_AI_ReadData (JY5500_DeviceHandle hDevice, double *dataBuffer, unsigned int dataLength, int timeOut, unsigned int *actualReadLength)
Read AI data to user defined data buffer. More...
JY5500API int | JY5500_AI_Stop (JY5500_DeviceHandle hDevice)
Stop AI acquisition. More...
JY5500API int | JY5500_AI_ReadRawData (JY5500_DeviceHandle hDevice, int *dataBuffer, unsigned int dataLength, int timeOut, unsigned int *actualReadLength)
Read AI raw data to user defined data buffer. More...
JY5500API int | JY5500_AI_SetSampleClock (JY5500_DeviceHandle hDevice, JY5500_ClockSource clockSource, JY5500_ExternalClockTerminal terminal, double expectedRate)
Set AI sampling clock source. More...
JY5500API int | JY5500_AI_ReadSinglePoint (JY5500_DeviceHandle hDevice, double *readValue, int channelID)
Read single point for each channel to user defined data buffer. More...
JY5500API int | JY5500_AI_ReadRawSinglePoint (JY5500_DeviceHandle hDevice, unsigned int *readValue, int channelID)
Read raw single point for each channel to user defined data buffer. More...
JY5500API int | JY5500_AI_SetStartTriggerType (JY5500_DeviceHandle hDevice, JY5500_AI_TriggerType triggerType)
Set AI start trigger type,the triggerType is defined by enum JY5500_AI_TriggerType. More...
JY5500API int | JY5500_AI_SetDigitalStartTrigger (JY5500_DeviceHandle hDevice, JY5500_DigitalTriggerSource triggerSource, JY5500_DigitalTriggerEdge triggerEdge)
Set AI digital start trigger,the triggerSource is defined by enum JY5500_DigitalTriggerSource, the triggerEdge is defined by enum JY5500_DigitalTriggerEdge. More...
JY5500API int | JY5500_AI_SetAnalogWindowStartTrigger (JY5500_DeviceHandle hDevice, JY5500_AnalogTriggerSource triggerSource, JY5500_AnalogWindowCondition triggerCondition, double highThreshold, double lowThreshold)
Set AI analog window start trigger,the triggerSource is defined by enum JY5500_AnalogTriggerSource, the triggerCondition is defined by enum JY5500_AnalogWindowCondition. More...
JY5500API int | JY5500_AI_SetAnalogHysteresisStartTrigger (JY5500_DeviceHandle hDevice, JY5500_AnalogTriggerSource triggerSource, JY5500_AnalogTriggerEdge triggerEdge, double highThreshold, double lowThreshold)
Set AI analog hysteresis start trigger,the triggerSource is defined by enum JY5500_AnalogTriggerSource, the triggerEdge is defined by enum JY5500_AnalogTriggerEdge. More...
JY5500API int | JY5500_AI_SetAnalogEdgeStartTrigger (JY5500_DeviceHandle hDevice, JY5500_AnalogTriggerSource triggerSource, JY5500_AnalogTriggerEdge triggerEdge, double threshold)
Set AI analog edge start trigger,the triggerSource is defined by enum JY5500_AnalogTriggerSource, the triggerEdge is defined by enum JY5500_AnalogTriggerEdge. More...
JY5500API int | JY5500_AI_SetReferenceTriggerType (JY5500_DeviceHandle hDevice, JY5500_AI_TriggerType triggerType)
Set AI reference trigger type,the triggerType is defined by enum JY5500_AI_TriggerType More...
JY5500API int | JY5500_AI_SetDigitalReferenceTrigger (JY5500_DeviceHandle hDevice, JY5500_DigitalTriggerSource triggerSource, JY5500_DigitalTriggerEdge triggerEdge)
Set AI digital reference trigger.the triggerSource is defined by enum JY5500_DigitalTriggerSource, the triggerEdge is defined by enum JY5500_DigitalTriggerEdge. More...
JY5500API int | JY5500_AI_SetAnalogWindowReferenceTrigger (JY5500_DeviceHandle hDevice, JY5500_AnalogTriggerSource triggerSource, JY5500_AnalogWindowCondition triggerCondition, double highThreshold, double lowThreshold)
Set AI analog window reference trigger,the triggerSource is defined by enum JY5500_AnalogTriggerSource, the triggerCondition is defined by enum JY5500_AnalogWindowCondition. More...
JY5500API int | JY5500_AI_SetAnalogHysteresisReferenceTrigger (JY5500_DeviceHandle hDevice, JY5500_AnalogTriggerSource triggerSource, JY5500_AnalogTriggerEdge triggerEdge, double highThreshold, double lowThreshold)
Set AI analog hysteresis reference trigger,the triggerSource is defined by enum JY5500_AnalogTriggerSource, the triggerEdge is defined by enum JY5500_AnalogTriggerEdge. More...
JY5500API int | JY5500_AI_SetAnalogEdgeReferenceTrigger (JY5500_DeviceHandle hDevice, JY5500_AnalogTriggerSource triggerSource, JY5500_AnalogTriggerEdge triggerEdge, double threshold)
Set AI analog edge window reference trigger,the triggerSource is defined by enum JY5500_AnalogTriggerSource, the triggerEdge is defined by enum JY5500_AnalogTriggerEdge. More...
JY5500API int | JY5500_AI_SetPreTriggerSamples (JY5500_DeviceHandle hDevice, unsigned int preTriggerSamples)
Set AI pretrigger samples, the samples must greater than 0. More...
JY5500API int | JY5500_AI_SetReTriggerCount (JY5500_DeviceHandle hDevice, unsigned long long reTriggerCount)
Set AI retrigger count. More...
JY5500API int | JY5500_AI_SendSoftTrigger (JY5500_DeviceHandle hDevice, JY5500_TriggerMode triggerMode)
Send the software trigger signal. More...
JY5500API int | JY5500_AI_WaitUntilDone (JY5500_DeviceHandle hDevice, bool *done)
Check if AI acquisition is completed in finite mode. More...
JY5500API int | JY5500_AI_CheckBufferStatusEx (JY5500_DeviceHandle hDevice, unsigned long long *avaliableSamples, unsigned long long *transferedSamples, bool *overrun)
Check AI task buffer status. More...
JY5500API int | JY5500_AI_CheckBufferStatus (JY5500_DeviceHandle hDevice, unsigned long long *avaliableSamples, bool *overrun)
Check AI task buffer status.This API is intended to be compatible with older version drivers. More...
JY5500API int | JY5500_AI_SetDSMode (JY5500_DeviceHandle hDevice, bool enable, JY5500_PowerLineFrequency powerFrequency)
Set AI DSMode More...
JY5500API int | JY5500_DI_AddLines (JY5500_DeviceHandle hDevice, unsigned int *port, unsigned int portCount)
Enabled DI channels. More...
JY5500API int | JY5500_DI_ReadData (JY5500_DeviceHandle hDevice, unsigned int *dataBuffer, unsigned int dataLength, int timeOut, unsigned int *actualReadLength)
Read DI data. More...
JY5500API int | JY5500_DI_ReadSinglePoint (JY5500_DeviceHandle hDevice, bool *readValues, int portID)
read single data from a single port by portID defined.if the portID == -1,read all port data.The data type is bool, one bool defined one line status. More...
JY5500API int | JY5500_DI_ReadSinglePoint_U8 (JY5500_DeviceHandle hDevice, unsigned char *readValues, int portID)
read single data from a single port by portID defined.if the portID == -1,read all port data.The data type is unsigned char, one char defined one port status. More...
JY5500API int | JY5500_DI_ReadSinglePoint_U64 (JY5500_DeviceHandle hDevice, unsigned long long *readValue)
read single data from a single port by portID defined.if the portID == -1,read all port data.The data type is unsigned long long,There are 6 ports, from 0 to 5. More...
JY5500API int | JY5500_DI_SetSampleRate (JY5500_DeviceHandle hDevice, double sampleRate, double *actualSampleRate)
Set DI sampling rate. More...
JY5500API int | JY5500_DI_SetSampleClock (JY5500_DeviceHandle hDevice, JY5500_ClockSource clockSource, JY5500_ExternalClockTerminal terminal, double expectedRate)
Set DI sampling clock source. More...
JY5500API int | JY5500_DI_Start (JY5500_DeviceHandle hDevice)
Start DI acquisition. More...
JY5500API int | JY5500_DI_Stop (JY5500_DeviceHandle hDevice)
Stop DI acquisition. More...
JY5500API int | JY5500_DI_SetMode (JY5500_DeviceHandle hDevice, JY5500_DI_SampleMode mode)
Set DI sampling mode.The mode defined by enum JY5500_DI_SampleMode. More...
JY5500API int | JY5500_DI_SetSamplesToAcquire (JY5500_DeviceHandle hDevice, int samplesToAcquire)
Set DI samples to acquire for each channel in finite mode.The samples range is 1 to 16M samples. More...
JY5500API int | JY5500_DI_CheckBufferStatus (JY5500_DeviceHandle hDevice, unsigned long long *avaliableSamples, bool *overrun)
Check DI device buffer status.This API is intended to be compatible with older version drivers. More...
JY5500API int | JY5500_DI_CheckBufferStatusEx (JY5500_DeviceHandle hDevice, unsigned long long *avaliableSamples, unsigned long long *transferedSamples, bool *overrun)
Check DI device buffer status. More...
JY5500API int | JY5500_DI_SetStartTriggerType (JY5500_DeviceHandle hDevice, JY5500_DI_TriggerType triggerType)
Set DI start trigger type,the triggerType is defined by enum JY5500_DI_TriggerType More...
JY5500API int | JY5500_DI_SetDigitalStartTrigger (JY5500_DeviceHandle hDevice, JY5500_DigitalTriggerSource triggerSource, JY5500_DigitalTriggerEdge triggerEdge)
Set DI digital start trigger,the triggerSource is defined by enum JY5500_DigitalTriggerSource, the triggerEdge is defined by enum JY5500_DigitalTriggerEdge. More...
JY5500API int | JY5500_DI_SetReferenceTriggerType (JY5500_DeviceHandle hDevice, JY5500_DI_TriggerType triggerType)
Set DI reference trigger type,the triggerType is defined by enum JY5500_DI_TriggerType. More...
JY5500API int | JY5500_DI_SetDigitalReferenceTrigger (JY5500_DeviceHandle hDevice, JY5500_DigitalTriggerSource triggerSource, JY5500_DigitalTriggerEdge triggerEdge)
Set AI digital reference trigger,the triggerSource is defined by enum JY5500_DigitalTriggerSource, the triggerEdge is defined by enum JY5500_DigitalTriggerEdge. More...
JY5500API int | JY5500_DI_SetPreTriggerSamples (JY5500_DeviceHandle hDevice, unsigned int preTriggerSamples)
Set DI pretrigger samples, the samples must greater than 0. More...
JY5500API int | JY5500_DI_SendSoftTrigger (JY5500_DeviceHandle hDevice, JY5500_TriggerMode triggerMode)
Send the software trigger signal. More...
JY5500API int | JY5500_DI_WaitUntilDone (JY5500_DeviceHandle hDevice, bool *done)
Check if DI acquisition is completed in finite mode. More...
JY5500API int | JY5500_DO_AddLines (JY5500_DeviceHandle hDevice, unsigned int *port, unsigned int portCount)
Enabled DO channels More...
JY5500API int | JY5500_DO_WriteData (JY5500_DeviceHandle hDevice, unsigned int *dataBuffer, unsigned int dataLength, int timeOut, unsigned int *actualWriteLength)
DO write data.The data type is uint. More...
JY5500API int | JY5500_DO_WriteSinglePoint (JY5500_DeviceHandle hDevice, bool *writeValues, int portID)
write single data to the port by portID defined.if the portID == -1,write all port data. More...
JY5500API int | JY5500_DO_WriteSinglePoint_U8 (JY5500_DeviceHandle hDevice, unsigned char *writeValue, int portID)
write single data to the port by portID defined.if the portID == -1,write all port data.The data type is unsigned char, one char defined one port status. More...
JY5500API int | JY5500_DO_WriteSinglePoint_U64 (JY5500_DeviceHandle hDevice, unsigned long long writeValues)
write single data to the port by portID defined.if the portID == -1,write all port data.The data type is unsigned long long,There are 6 ports, from 0 to 5. More...
JY5500API int | JY5500_DO_SetUpdateRate (JY5500_DeviceHandle hDevice, double sampleRate, double *actualSampleRate)
Set DO update rate.The update rate is the same for all channels. More...
JY5500API int | JY5500_DO_Start (JY5500_DeviceHandle hDevice)
Start digital signal output. More...
JY5500API int | JY5500_DO_Stop (JY5500_DeviceHandle hDevice)
Stop digital signal output. More...
JY5500API int | JY5500_DO_SetMode (JY5500_DeviceHandle hDevice, JY5500_DO_UpdateMode mode)
Set digital signal output mode, the mode defined by enum JY5500_AO_UpdateMode. More...
JY5500API int | JY5500_DO_SetSamplesToUpdate (JY5500_DeviceHandle hDevice, int samplesToUpdate)
Set digital signal output samples for each channel in finite mode.The samples range is 1 to 16M samples. More...
JY5500API int | JY5500_DO_SetSampleClock (JY5500_DeviceHandle hDevice, JY5500_ClockSource clockSource, JY5500_ExternalClockTerminal terminal, double expectedRate)
Set DO sampling clock source. More...
JY5500API int | JY5500_DO_CheckBufferStatus (JY5500_DeviceHandle hDevice, unsigned long *avaliableSamples, bool *overrun)
Check DO device buffer status.This API is intended to be compatible with older version drivers. More...
JY5500API int | JY5500_DO_CheckBufferStatusEx (JY5500_DeviceHandle hDevice, unsigned long *avaliableSamples, unsigned long long *transferedSamples, bool *overrun)
Check DO device buffer status. More...
JY5500API int | JY5500_DO_WaitUntilDone (JY5500_DeviceHandle hDevice, bool *done, int timeOut)
Check finite digital signal output is complete. More...
JY5500API int | JY5500_DO_SetStartTriggerType (JY5500_DeviceHandle hDevice, JY5500_DO_TriggerType triggerType)
Set DO start trigger type,the triggerType is defined by enum JY5500_DO_TriggerType. More...
JY5500API int | JY5500_DO_SetDigitalStartTrigger (JY5500_DeviceHandle hDevice, JY5500_DigitalTriggerSource triggerSource, JY5500_DigitalTriggerEdge triggerEdge)
Set DO digital start trigger,the triggerSource is defined by enum JY5500_DigitalTriggerSource, the triggerEdge is defined by enum JY5500_DigitalTriggerEdge. More...
JY5500API int | JY5500_DO_SendSoftTrigger (JY5500_DeviceHandle hDevice)
Send the software trigger signal. More...
JY5500API int | JY5500_AO_EnableChannel (JY5500_DeviceHandle hDevice, unsigned int channelCount, unsigned char *channels, double *lowRegion, double *highRegion)
Enables AO channels. More...
JY5500API int | JY5500_AO_SetUpdateRate (JY5500_DeviceHandle hDevice, double updateRate, double *actualUpdateRate)
Set AO update rate for each channel. More...
JY5500API int | JY5500_AO_SetMode (JY5500_DeviceHandle hDevice, JY5500_AO_UpdateMode mode)
Set AO mode, the mode defined by enum JY5500_AO_UpdateMode. More...
JY5500API int | JY5500_AO_SetSamplesToUpdate (JY5500_DeviceHandle hDevice, unsigned int sampleToUpdate)
Set AO samples for each channel in the finite mode.The sample range is from 1 to 32M / channelCount samples. More...
JY5500API int | JY5500_AO_Start (JY5500_DeviceHandle hDevice)
Start digital signal output. More...
JY5500API int | JY5500_AO_WriteRawData (JY5500_DeviceHandle hDevice, short *dataBuffer, unsigned int dataLength, int timeOut, unsigned int *actualWriteLength)
AO write raw data.The data is interleaved in the buffer in channel order for multi-channel. More...
JY5500API int | JY5500_AO_WriteData (JY5500_DeviceHandle hDevice, double *dataBuffer, unsigned int dataLength, int timeOut, unsigned int *actualWriteLength)
AO writes data.The data is interleaved in the buffer the order defined by JY5500_AO_EnableChannel. More...
JY5500API int | JY5500_AO_Stop (JY5500_DeviceHandle hDevice)
Stop analog signal output. More...
JY5500API int | JY5500_AO_SetSampleClock (JY5500_DeviceHandle hDevice, JY5500_ClockSource clockSource, JY5500_ExternalClockTerminal terminal, double expectedRate)
Set AO sampling clock source. More...
JY5500API int | JY5500_AO_WriteRawSinglePoint (JY5500_DeviceHandle hDevice, unsigned short *writeValues, int channelID)
AO write single point raw data to the defined channel by channelID, if channelID == -1, write all enable channel. More...
JY5500API int | JY5500_AO_WriteSinglePoint (JY5500_DeviceHandle hDevice, double *writeValues, int channelID)
AO write single point data to the defined channel by channelID, if channelID == -1, write all enable channel one data. More...
JY5500API int | JY5500_AO_SetStartTriggerType (JY5500_DeviceHandle hDevice, JY5500_AO_TriggerType triggerType)
Set AO start trigger type,the triggerType is defined by enum JY5500_AO_TriggerType. More...
JY5500API int | JY5500_AO_SetDigitalStartTrigger (JY5500_DeviceHandle hDevice, JY5500_DigitalTriggerSource triggerSource, JY5500_DigitalTriggerEdge triggerEdge)
Set AO digital start trigger,the triggerSource is defined by enum JY5500_DigitalTriggerSource, the triggerEdge is defined by enum JY5500_DigitalTriggerEdge. More...
JY5500API int | JY5500_AO_WaitUntilDone (JY5500_DeviceHandle hDevice, bool *done, int timeOut)
Check AO finite output is complete. More...
JY5500API int | JY5500_AO_CheckBufferStatusEx (JY5500_DeviceHandle hDevice, unsigned long *avaliableSamples, unsigned long long *transferedSamples, bool *overrun)
Check AO task buffer status. More...
JY5500API int | JY5500_AO_CheckBufferStatus (JY5500_DeviceHandle hDevice, unsigned long *avaliableSamples, bool *overrun)
Check AO task buffer status. More...
JY5500API int | JY5500_AO_SendSoftTrigger (JY5500_DeviceHandle hDevice)
Send the software trigger signal. More...
JY5500API int | JY5500_CI_EnableChannel (JY5500_DeviceHandle hDevice, unsigned int channel)
Enables CI channel.There are 4 counter,from 0 to 3. More...
JY5500API int | JY5500_CI_SetCounterType (JY5500_DeviceHandle hDevice, unsigned int channel, JY5500_CI_MeasureType measureType)
Set CI measure type More...
JY5500API int | JY5500_CI_SetSignalReverse (JY5500_DeviceHandle hDevice, unsigned int channel, int signalReverse)
Set the Signal Reverse terminal. More...
JY5500API int | JY5500_CI_SetCounterParament (JY5500_DeviceHandle hDevice, unsigned int channel, int initCount, JY5500_CountDirection countDirection)
Set CI count parameter More...
JY5500API int | JY5500_CI_SetZReloadEnabled (JY5500_DeviceHandle hDevice, unsigned int channel, bool zReloadEnabled)
Set the Z signal enable in Encoder mode. More...
JY5500API int | JY5500_CI_SetMode (JY5500_DeviceHandle hDevice, unsigned int channel, JY5500_CI_SampleMode mode)
Set counter input mode, the mode is defined by enum JY5500_CI_SampleMode. More...
JY5500API int | JY5500_CI_SetSampleClock (JY5500_DeviceHandle hDevice, unsigned int channel, JY5500_CI_SampleClock clock, JY5500_ExternalClockTerminal terminal, double rate)
Set counter input sampling clock source. More...
JY5500API int | JY5500_CI_SetSamplesToAcquire (JY5500_DeviceHandle hDevice, unsigned int channel, unsigned int samplesToAcquire)
Set samples to acquire in finite mode.The samples range is 1 to 4M. More...
JY5500API int | JY5500_CI_SetEdgeCountEvent (JY5500_DeviceHandle hDevice, unsigned int channel, JY5500_CI_CounterEventSignalIdleState idleState, unsigned int threshold)
Set the counter threshold, and when the count reaches this threshold, output a single pulse at the output terminal More...
JY5500API int | JY5500_CI_SetPauseTriggerLevel (JY5500_DeviceHandle hDevice, unsigned int channel, bool enable, JY5500_LevelState pauseTriggerActiveLevel)
Config CI pause trigger. More...
JY5500API int | JY5500_CI_ReadSingleCountValue (JY5500_DeviceHandle hDevice, unsigned int channel, unsigned int *countValue)
Counter reads a single count value, this API supports the CI Type: JY5500_CI_EdgeCount、JY5500_CI_EncoderX1、 JY5500_CI_EncoderX2 、 JY5500_CI_EncoderX4 、JY5500_CI_EncoderTwoPulse. More...
JY5500API int | JY5500_CI_ReadSingleMeasureValue (JY5500_DeviceHandle hDevice, unsigned int channel, double *measureValue1, double *measureValue2, int timeOut)
Reads a single counter measurement as follows. More...
JY5500API int | JY5500_CI_ReadCountValues (JY5500_DeviceHandle hDevice, unsigned int channel, unsigned int *countValues, unsigned int dataLength, int timeOut, unsigned int *actualReadLength)
Counter reads the count values, this API is supprot CI Type ：JY5500_CI_EdgeCount、JY5500_CI_EncoderX1、 JY5500_CI_EncoderX2 、 JY5500_CI_EncoderX4 、JY5500_CI_EncoderTwoPulse. More...
JY5500API int | JY5500_CI_ReadMeasureValues (JY5500_DeviceHandle hDevice, unsigned int channel, double *measureValues1, double *measureValues2, unsigned int dataLength, int timeOut, unsigned int *actualReadLength)
Counter reads the measured values, this API only support CI Type for JY5500_CI_Measure_EdgeSeparation JY5500_CI_Measure_Pulse JY5500_CI_Measure_Frequency JY5500_CI_Measure_Period for JY5500_CI_Measure_EdgeSeparation type, the measureValues1 is the Gate signel to the Aux signal interval, the measureValues2 is the Aux signel to the Gate signal interval, the unit is s. More...
JY5500API int | JY5500_CI_Start (JY5500_DeviceHandle hDevice, unsigned int channel)
Start Counter input. More...
JY5500API int | JY5500_CI_Stop (JY5500_DeviceHandle hDevice, unsigned int channel)
Stop Counter input. More...
JY5500API int | JY5500_CI_CheckBufferStatus (JY5500_DeviceHandle hDevice, unsigned int channel, unsigned long long *avaliableSamples, bool *overrun)
Check CI task buffer status. More...
JY5500API int | JY5500_CI_CheckBufferStatusEx (JY5500_DeviceHandle hDevice, unsigned int channel, unsigned long long *avaliableSamples, unsigned long long *transferedSamples, bool *overrun)
Check CI task buffer status. More...
JY5500API int | JY5500_CI_SetTimeBase (JY5500_DeviceHandle hDevice, int channel, JY5500_CountTimeBase timeBase)
Set counter input time base,the time base defined by enum JY5500_CountTimeBase. More...
JY5500API int | JY5500_CI_SendSoftTrigger (JY5500_DeviceHandle hDevice, int channel)
Send the software trigger signal for CI. More...
JY5500API int | JY5500_CI_SetStartTriggerType (JY5500_DeviceHandle hDevice, int channel, JY5500_CIO_TriggerType triggerTyp)
Set CI start trigger type,the triggerType is defined by enum JY5500_CI_TriggerType. More...
JY5500API int | JY5500_CI_SetDigitalStartTrigger (JY5500_DeviceHandle hDevice, int channel, JY5500_DigitalTriggerSource triggerSource, JY5500_DigitalTriggerEdge triggerEdge)
Set CI digital start trigger.the triggerSource is defined by enum JY5500_DigitalTriggerSource, the triggerEdge is defined by enum JY5500_DigitalTriggerEdge. More...
JY5500API int | JY5500_CO_EnableChannel (JY5500_DeviceHandle hDevice, unsigned int channel)
Enabled counter output channel. More...
JY5500API int | JY5500_CO_SetCounterParament (JY5500_DeviceHandle hDevice, unsigned int channel, int pulseCount, JY5500_CO_IdleState IdleState, double delay)
Set CO parameter. More...
JY5500API int | JY5500_CO_SetFrequency (JY5500_DeviceHandle hDevice, unsigned int channel, unsigned int highTicks, unsigned int lowTicks)
Set counter output pulse frequency More...
JY5500API int | JY5500_CO_SetFrequencyOnFly (JY5500_DeviceHandle hDevice, unsigned int channel, unsigned int highTicks, unsigned int lowTicks)
Set the output pulse frequency of the counter in real time. More...
JY5500API int | JY5500_CO_WriteData (JY5500_DeviceHandle hDevice, int channel, unsigned int *dataBuffer, unsigned int dataLength, int timeOut, unsigned int *actualWriteLength)
CO write data.One sampling point consists of three datas, high level ticks, low level ticks, and number of pulses. More...
JY5500API int | JY5500_CO_CheckBufferStatus (JY5500_DeviceHandle hDevice, unsigned int channel, unsigned long *avaliableSamples, bool *overrun)
Check CO task buffer status.This API is intended to be compatible with older version drivers. More...
JY5500API int | JY5500_CO_CheckBufferStatusEx (JY5500_DeviceHandle hDevice, unsigned int channel, unsigned long *avaliableSamples, unsigned long long *transferedSamples, bool *overrun)
Check CO task buffer status. More...
JY5500API int | JY5500_CO_CheckCounterStatus (JY5500_DeviceHandle hDevice, unsigned int channel, unsigned int *pulseTransfered, bool *underflow)
Check counter output status. More...
JY5500API int | JY5500_CO_WaitUntilDone (JY5500_DeviceHandle hDevice, unsigned int channel, bool *done)
Check counter output complete status. More...
JY5500API int | JY5500_CO_SetSamplesToUpdate (JY5500_DeviceHandle hDevice, unsigned int channel, unsigned int samplesToUpdate)
Set CO samples for each channel in the finite mode.The sample range is from 1 to 4M samples. More...
JY5500API int | JY5500_CO_Start (JY5500_DeviceHandle hDevice, unsigned int channel)
Start counter output. More...
JY5500API int | JY5500_CO_Stop (JY5500_DeviceHandle hDevice, unsigned int channel)
Stop counter output. More...
JY5500API int | JY5500_CO_SetTimeBase (JY5500_DeviceHandle hDevice, int channel, JY5500_CountTimeBase timeBase)
Set CO timebase source More...
JY5500API int | JY5500_CO_SendSoftTrigger (JY5500_DeviceHandle hDevice, int channel)
Send the software trigger signal. More...
JY5500API int | JY5500_CO_SetMode (JY5500_DeviceHandle hDevice, unsigned int channel, JY5500_CO_OUTMode mode)
Set counter output mode, the mode defined by enum JY5500_CO_UpdateMode. More...
JY5500API int | JY5500_CO_SetStartTriggerType (JY5500_DeviceHandle hDevice, int channel, JY5500_CIO_TriggerType triggerTyp)
Set CO start trigger type,the triggerType is defined by enum JY5500_AI_TriggerType More...
JY5500API int | JY5500_CO_SetDigitalStartTrigger (JY5500_DeviceHandle hDevice, int channel, JY5500_DigitalTriggerSource triggerSource, JY5500_DigitalTriggerEdge triggerEdge)
Set CO digital start trigger,the triggerSource is defined by enum JY5500_DigitalTriggerSource, the triggerEdge is defined by enum JY5500_DigitalTriggerEdge. More...
JY5500API int | JY5500_DisableAICalibration (JY5500_DeviceHandle hDevice, bool DisableCalibration)
Disable AI calibration coefficient, default enable calibration coefficient More...
JY5500API int | JY5500_DisableAOCalibration (JY5500_DeviceHandle hDevice, bool DisableCalibration)
Disable AO calibration coefficient, default enable calibration coefficient More...
JY5500API int | JY5500_SetPFIFilter (JY5500_DeviceHandle hDevice, int line, bool filterEnabled, int minPulseWidth, int *actualMinPulseWidth)
Set the filter for the specified PFI More...

Detailed Description

@SectionBegin JY5500 FileHead

COPYRIGHT NOTICE
Copyright (c) 2018-2022, JYTEK
All rights reserved.
Author
JYTEK
Version
4.1.0
Date
2022-9-30

This header file defines C/C++ API and enums used in the JY5500 driver.

Revision Notes:

Typedef Documentation

◆ JY5500_DeviceHandle

typedef void* JY5500_DeviceHandle

@SectionEnd JY5500_Device FileHead

Windows Linux

Enumeration Type Documentation

◆ JY5500_AI_SampleMode

enum JY5500_AI_SampleMode
Enumerator
JY5500_AI_Finite | AI Finite mode.
JY5500_AI_Continuous | AI Continuous mode.
JY5500_AI_Single | AI Single mode.

◆ JY5500_AI_Terminal

enum JY5500_AI_Terminal
Enumerator
JY5500_AI_RSE | AI RSE connection mode.
JY5500_AI_NRSE | AI NRSE connection mode.
JY5500_AI_Diff | AI Diff connection mode.

◆ JY5500_AI_TriggerType

enum JY5500_AI_TriggerType
Enumerator
JY5500_AI_Immediately | AI Immediately trigger.
JY5500_AI_Digital | AI Digital trigger.
JY5500_AI_Analog | AI Analog trigger.
JY5500_AI_Soft | AI Soft trigger.

◆ JY5500_AnalogTriggerEdge

enum JY5500_AnalogTriggerEdge
Enumerator
JY5500_RisingSlope | Rsing edge for Analog trigger.
JY5500_FallingSlope | Falling edge for Analog trigger.

◆ JY5500_AnalogTriggerSource

enum JY5500_AnalogTriggerSource
Enumerator
JY5500_Channel_0
JY5500_Channel_1
JY5500_Channel_2
JY5500_Channel_3
JY5500_Channel_4
JY5500_Channel_5
JY5500_Channel_6
JY5500_Channel_7
JY5500_Channel_8
JY5500_Channel_9
JY5500_Channel_10
JY5500_Channel_11
JY5500_Channel_12
JY5500_Channel_13
JY5500_Channel_14
JY5500_Channel_15
JY5500_Channel_16
JY5500_Channel_17
JY5500_Channel_18
JY5500_Channel_19
JY5500_Channel_20
JY5500_Channel_21
JY5500_Channel_22
JY5500_Channel_23
JY5500_Channel_24
JY5500_Channel_25
JY5500_Channel_26
JY5500_Channel_27
JY5500_Channel_28
JY5500_Channel_29
JY5500_Channel_30
JY5500_Channel_31

◆ JY5500_AnalogWindowCondition

enum JY5500_AnalogWindowCondition
Enumerator
JY5500_Entering | Analog Window trigger condition is Entering.
JY5500_Leaving | Analog Window trigger condition is Leaving.

◆ JY5500_AO_TriggerType

enum JY5500_AO_TriggerType
Enumerator
JY5500_AO_Immediately | AO Immediately trigger.
JY5500_AO_Digital | AO Digital trigger.
JY5500_AO_Soft | AO Soft trigger.

◆ JY5500_AO_UpdateMode

enum JY5500_AO_UpdateMode
Enumerator
JY5500_AO_Finite | AO Finite mode.
JY5500_AO_ContinuousWrapping | AO ContinuousWrapping mode.
JY5500_AO_ContinuousNoWrapping | AO ContinuousNoWrapping mode.
JY5500_AO_Single | AO Single mode.

◆ JY5500_CI_CounterEventSignalIdleState

enum JY5500_CI_CounterEventSignalIdleState

CI Counter Event Signal Idle State.

Enumerator
JY5500_CI_CounterEventSignalIdleState_Low | Low Level as the CI Counter Event Signal Idle State.
JY5500_CI_CounterEventSignalIdleState_High | High Level as the CI Counter Event Signal Idle State.

◆ JY5500_CI_MeasureType

enum JY5500_CI_MeasureType
Enumerator
JY5500_CI_EdgeCount | Edge count.
JY5500_CI_Measure_FrequencyOrPeriod | FrequencyOrPeriod Measurement.
JY5500_CI_Measure_PulseWidth | Pulse Measurement.
JY5500_CI_Measure_EdgeSeparation | Two Edge Separation Measurement.
JY5500_CI_EncoderX1 | Quadrature Encoded X1.
JY5500_CI_EncoderX2 | Quadrature Encoded X2.
JY5500_CI_EncoderX4 | Quadrature Encoded X4.
JY5500_CI_EncoderTwoPulse | Two Pulse Encoder.

◆ JY5500_CI_SampleClock

enum JY5500_CI_SampleClock
Enumerator
JY5500_CI_ImplicitClock | CI Implicit Clock.
JY5500_CI_InternalClock | CI Internal Clock.
JY5500_CI_ExternalClock | CI External Clock.

◆ JY5500_CI_SampleMode

enum JY5500_CI_SampleMode
Enumerator
JY5500_CI_Finite | CI Finite mode.
JY5500_CI_Continuous | CI Continuous mode.
JY5500_CI_Single | CI Single mode.

◆ JY5500_CIO_TriggerType

enum JY5500_CIO_TriggerType
Enumerator
JY5500_CIO_Immediately | CI Immediately trigger.
JY5500_CIO_Digital | CI Digital trigger.
JY5500_CIO_Soft | CI Soft trigger.

◆ JY5500_ClockSource

enum JY5500_ClockSource
Enumerator
JY5500_InternalClock | Internal Clock Source.
JY5500_ExternalClock | External Clock Source.

◆ JY5500_CO_IdleState

enum JY5500_CO_IdleState
Enumerator
JY5500_CO_LowLevel | Low Level as the co idle state.
JY5500_CO_HighLevel | High Level as the co idle state.

◆ JY5500_CO_OUTMode

enum JY5500_CO_OUTMode
Enumerator
JY5500_CO_Finite | CO Finite mode.
JY5500_CO_ContinuousWrapping | CO ContinuousWrapping mode.
JY5500_CO_ContinuousNoWrapping | CO ContinuousNoWrapping mode.
JY5500_CO_Single | CO Finite mode.

◆ JY5500_CountDirection

enum JY5500_CountDirection
Enumerator
JY5500_CI_Count_Up | Increases count.
JY5500_CI_Count_Down | Reduction count.
JY5500_CI_Count_External | External terminal determines the count direction.

◆ JY5500_CountTimeBase

enum JY5500_CountTimeBase
Enumerator
JY5500_TimeBase_200M

Counter timebase 200 MHz.

◆ JY5500_DI_SampleMode

enum JY5500_DI_SampleMode
Enumerator
JY5500_DI_Finite | DI Finite mode.
JY5500_DI_Continuous | DI Continuous mode.
JY5500_DI_Single | DI Single mode.

◆ JY5500_DI_TriggerType

enum JY5500_DI_TriggerType
Enumerator
JY5500_DI_Immediately | DI Immediately trigger.
JY5500_DI_Digital | DI Digital trigger.
JY5500_DI_Soft | DI Soft trigger.

◆ JY5500_DigitalTriggerEdge

enum JY5500_DigitalTriggerEdge
Enumerator
JY5500_Rising | Rsing edge for digital trigger.
JY5500_Falling | Falling edge for digital trigger.

◆ JY5500_DigitalTriggerSource

enum JY5500_DigitalTriggerSource
Enumerator
JY5500_PFI0 | PFI_0 as the digital trigger source.
JY5500_PFI1 | PFI_1 as the digital trigger source.
JY5500_PFI2 | PFI_2 as the digital trigger source.
JY5500_PFI3 | PFI_3 as the digital trigger source.
JY5500_PFI4 | PFI_4 as the digital trigger source.
JY5500_PFI5 | PFI_5 as the digital trigger source.
JY5500_PFI6 | PFI_6 as the digital trigger source.
JY5500_PFI7 | PFI_7 as the digital trigger source.
JY5500_PFI8 | PFI_8 as the digital trigger source.
JY5500_PFI9 | PFI_9 as the digital trigger source.
JY5500_PFI10 | PFI_10 as the digital trigger source.
JY5500_PFI11 | PFI_11 as the digital trigger source.
JY5500_PFI12 | PFI_12 as the digital trigger source.
JY5500_PFI13 | PFI_13 as the digital trigger source.
JY5500_PFI14 | PFI_14 as the digital trigger source.
JY5500_PFI15 | PFI_15 as the digital trigger source.
JY5500_Inter_AI_StartTrig | AI_StartTrig as the digital trigger source.
JY5500_Inter_AI_ReferenceTrig | AI_ReferenceTrig as the digital trigger source.
JY5500_Inter_DI_StartTrig | DI_StartTrig as the digital trigger source.
JY5500_Inter_DI_ReferenceTrig | DI_ReferenceTrig as the digital trigger source.
JY5500_Inter_AO_StartTrig | AO_StartTrig as the digital trigger source.
JY5500_Inter_DO_StartTrig | DO_StartTrig as the digital trigger source.
JY5500_Inter_CI_0_StartTrig | CI0_StartTrig as the digital trigger source.
JY5500_Inter_CI_1_StartTrig | CI1_StartTrig as the digital trigger source.
JY5500_Inter_CI_2_StartTrig | CI2_StartTrig as the digital trigger source.
JY5500_Inter_CI_3_StartTrig | CI3_StartTrig as the digital trigger source.
JY5500_Inter_CO_0_StartTrig | CO0_StartTrig as the digital trigger source.
JY5500_Inter_CO_1_StartTrig | CO1_StartTrig as the digital trigger source.
JY5500_Inter_CO_2_StartTrig | CO2_StartTrig as the digital trigger source.
JY5500_Inter_CO_3_StartTrig | CO3_StartTrig as the digital trigger source.
JY5500_Inter_CO_0_Output_Trig | CO_0_Output as the digital trigger source.
JY5500_Inter_CO_1_Output_Trig | CO_1_Output as the digital trigger source.
JY5500_Inter_CO_2_Output_Trig | CO_2_Output as the digital trigger source.
JY5500_Inter_CO_3_Output_Trig | CO_3_Output as the digital trigger source.
JY5500_PXI_Trig0 | PXI_Trig0 as the digital trigger source.
JY5500_PXI_Trig1 | PXI_Trig1 as the digital trigger source.
JY5500_PXI_Trig2 | PXI_Trig2 as the digital trigger source.
JY5500_PXI_Trig3 | PXI_Trig3 as the digital trigger source.
JY5500_PXI_Trig4 | PXI_Trig4 as the digital trigger source.
JY5500_PXI_Trig5 | PXI_Trig5 as the digital trigger source.
JY5500_PXI_Trig6 | PXI_Trig6 as the digital trigger source.
JY5500_PXI_Trig7 | PXI_Trig7 as the digital trigger source.

◆ JY5500_DO_TriggerType

enum JY5500_DO_TriggerType
Enumerator
JY5500_DO_Immediately | DO Immediately trigger.
JY5500_DO_Digital | DO Digital trigger.
JY5500_DO_Soft | DO Soft trigger.

◆ JY5500_DO_UpdateMode

enum JY5500_DO_UpdateMode
Enumerator
JY5500_DO_Finite | DO Finite mode.
JY5500_DO_ContinuousWrapping | DO ContinuousWrapping mode.
JY5500_DO_ContinuousNoWrapping | DO ContinuousNoWrapping mode.
JY5500_DO_Single | DO Single mode.

◆ JY5500_ExternalClockTerminal

enum JY5500_ExternalClockTerminal
Enumerator
JY5500_ECLK | External Clock Source In Pin Define.
JY5500_Inter_AI_SampleClock | AI_SampleClock as other task External Clock Source.
JY5500_Inter_AO_SampleClock | AO_SampleClock as other task External Clock Source.
JY5500_Inter_DI_SampleClock | DI_SampleClock as other task External Clock Source.
JY5500_Inter_DO_SampleClock | DO_SampleClock as other task External Clock Source.
JY5500_Inter_CI0_SampleClock | CI0_SampleClock as other task External Clock Source.
JY5500_Inter_CI1_SampleClock | CI1_SampleClock as other task External Clock Source.
JY5500_Inter_CI2_SampleClock | CI2_SampleClock as other task External Clock Source.
JY5500_Inter_CI3_SampleClock | CI3_SampleClock as other task External Clock Source.
JY5500_Inter_CO_0_Output | CO_0_Output as other task External Clock Source.
JY5500_Inter_CO_1_Output | CO_1_Output as other task External Clock Source.
JY5500_Inter_CO_2_Output | CO_2_Output as other task External Clock Source.
JY5500_Inter_CO_3_Output | CO_3_Output as other task External Clock Source.
JY5500_PXI_Trig0_IN | PXI_Trig0 as External Clock Source.
JY5500_PXI_Trig1_IN | PXI_Trig1 as External Clock Source.
JY5500_PXI_Trig2_IN | PXI_Trig2 as External Clock Source.
JY5500_PXI_Trig3_IN | PXI_Trig3 as External Clock Source.
JY5500_PXI_Trig4_IN | PXI_Trig4 as External Clock Source.
JY5500_PXI_Trig5_IN | PXI_Trig5 as External Clock Source.
JY5500_PXI_Trig6_IN | PXI_Trig6 as External Clock Source.
JY5500_PXI_Trig7_IN | PXI_Trig7 as External Clock Source.

◆ JY5500_LevelState

enum JY5500_LevelState
Enumerator
JY5500_LowLevel | Low Level as the pause trigger active level.
JY5500_HighLevel | High Level as the pause trigger active level.

◆ JY5500_PowerLineFrequency

enum JY5500_PowerLineFrequency
Enumerator
JY5500_50_Hz
JY5500_60_Hz

◆ JY5500_ReferenceClock

enum JY5500_ReferenceClock
Enumerator
JY5500_Internal | The onboard 25 MHz as JY5500_ReferenceClock.
JY5500_PXIe_Clk100 | The PXIe chassis 100MHz as JY5500_ReferenceClock, only for PXIe module.

◆ JY5500_Signal_Destination

enum JY5500_Signal_Destination
Enumerator
JY5500_PFI0_OUT | PFI0 as the signal desition to rout.
JY5500_PFI1_OUT | PFI1 as the signal desition to rout.
JY5500_PFI2_OUT | PFI2 as the signal desition to rout.
JY5500_PFI3_OUT | PFI3 as the signal desition to rout.
JY5500_PFI4_OUT | PFI4 as the signal desition to rout.
JY5500_PFI5_OUT | PFI5 as the signal desition to rout.
JY5500_PFI6_OUT | PFI6 as the signal desition to rout.
JY5500_PFI7_OUT | PFI7 as the signal desition to rout.
JY5500_PFI8_OUT | PFI8 as the signal desition to rout.
JY5500_PFI9_OUT | PFI9 as the signal desition to rout.
JY5500_PFI10_OUT | PFI10 as the signal desition to rout.
JY5500_PFI11_OUT | PFI11 as the signal desition to rout.
JY5500_PFI12_OUT | PFI12 as the signal desition to rout.
JY5500_PFI13_OUT | PFI13 as the signal desition to rout.
JY5500_PFI14_OUT | PFI14 as the signal desition to rout.
JY5500_PFI15_OUT | PFI15 as the signal desition to rout.
JY5500_PXITrig0_OUT | PXITrig0 as the signal desition to rout.
JY5500_PXITrig1_OUT | PXITrig1 as the signal desition to rout.
JY5500_PXITrig2_OUT | PXITrig2 as the signal desition to rout.
JY5500_PXITrig3_OUT | PXITrig3 as the signal desition to rout.
JY5500_PXITrig4_OUT | PXITrig4 as the signal desition to rout.
JY5500_PXITrig5_OUT | PXITrig5 as the signal desition to rout.
JY5500_PXITrig6_OUT | PXITrig6 as the signal desition to rout.
JY5500_PXITrig7_OUT | PXITrig7 as the signal desition to rout.

◆ JY5500_Signal_Source

enum JY5500_Signal_Source
Enumerator
JY5500_AI_StartTrig | AI_StartTrig as the source signal to rout.
JY5500_AI_ReferenceTrig | AI_ReferenceTrig as the source signal to rout.
JY5500_DI_StartTrig | DI_StartTrig as the source signal to rout.
JY5500_DI_ReferenceTrig | DI_ReferenceTrig as the source signal to rout.
JY5500_AO_StartTrig | AO_StartTrig as the source signal to rout.
JY5500_DO_StartTrig | DO_StartTrig as the source signal to rout.
JY5500_CI_0_StartTrig | CI0_StartTrig as the source signal to rout.
JY5500_CI_1_StartTrig | CI1_StartTrig as the source signal to rout.
JY5500_CI_2_StartTrig | CI2_StartTrig as the source signal to rout.
JY5500_CI_3_StartTrig | CI3_StartTrig as the source signal to rout.
JY5500_CO_0_StartTrig | CO0_StartTrig as the source signal to rout.
JY5500_CO_1_StartTrig | CO1_StartTrig as the source signal to rout.
JY5500_CO_2_StartTrig | CO2_StartTrig as the source signal to rout.
JY5500_CO_3_StartTrig | CO3_StartTrig as the source signal to rout.
JY5500_AI_SampleClock | AI_SampleClock as the source signal to rout.
JY5500_AO_SampleClock | AO_SampleClock as the source signal to rout.
JY5500_DI_SampleClock | DI_SampleClock as the source signal to rout.
JY5500_DO_SampleClock | DO_SampleClock as the source signal to rout.
JY5500_CI_0_SampleClock | CI0_SampleClock as the source signal to rout.
JY5500_CI_1_SampleClock | CI1_SampleClock as the source signal to rout.
JY5500_CI_2_SampleClock | CI2_SampleClock as the source signal to rout.
JY5500_CI_3_SampleClock | CI3_SampleClock as the source signal to rout.
JY5500_CO_0_Output | CO_0_Output as the source signal to rout.
JY5500_CO_1_Output | CO_1_Output as the source signal to rout.
JY5500_CO_2_Output | CO_2_Output as the source signal to rout.
JY5500_CO_3_Output | CO_3_Output as the source signal to rout.

◆ JY5500_TriggerMode

enum JY5500_TriggerMode
Enumerator
JY5500_StartTrigger | Start trigger mode.
JY5500_ReferenceTrigger | Reference trigger mode.

Function Documentation

◆ JY5500_AI_CheckBufferStatus()

JY5500API int JY5500_AI_CheckBufferStatus | ( | JY5500_DeviceHandle | hDevice,
 |  | unsigned long long * | avaliableSamples,
 |  | bool * | overrun
 | ) |  |

Check AI task buffer status.This API is intended to be compatible with older version drivers.

It is recommended to use API JY5500_AI_CheckBufferStatusEx.

Parameters
hDevice | device handle
avaliableSamples | number of samples per channel in the device buffer
overrun | true if overflow, false if not overflow.
Returns
0 if success or other error code

◆ JY5500_AI_CheckBufferStatusEx()

JY5500API int JY5500_AI_CheckBufferStatusEx | ( | JY5500_DeviceHandle | hDevice,
 |  | unsigned long long * | avaliableSamples,
 |  | unsigned long long * | transferedSamples,
 |  | bool * | overrun
 | ) |  |

Check AI task buffer status.

Parameters
hDevice | device handle
avaliableSamples | number of samples per channel in the device buffer
transferedSamples | The number of samples that have been transfered from the device buffer (per channel)
overrun | true if overflow, false if not overflow.
Returns
0 if success or other error code

◆ JY5500_AI_EnableChannel()

JY5500API int JY5500_AI_EnableChannel | ( | JY5500_DeviceHandle | hDevice,
 |  | unsigned int | channelCount,
 |  | unsigned char * | channels,
 |  | double * | lowRegion,
 |  | double * | highRegion,
 |  | JY5500_AI_Terminal * | terminal
 | ) |  |

Enable AI channels.

Each channel can be independently configured

Parameters
hDevice | device handle
channelCount | number of channels to be enabled
channels | array[channelCount] containing channel IDs
lowRegion | array[channelCount] of lower limit numbers for each channel,typically in volts.
highRegion | array[channelCount] of higher limit numbers for each channel, typcially in volts.
terminal | array[channelCount] of the terminal configuration defined by enum JY5500_AI_Terminal which can be RSE,NRSE,or DIFF.
Returns
0 if success or other error code

◆ JY5500_AI_ReadData()

JY5500API int JY5500_AI_ReadData | ( | JY5500_DeviceHandle | hDevice,
 |  | double * | dataBuffer,
 |  | unsigned int | dataLength,
 |  | int | timeOut,
 |  | unsigned int * | actualReadLength
 | ) |  |

Read AI data to user defined data buffer.

For the multi-channel acquisition, the data is interleaved in the order defined by JY5500_AI_EnableChannel.

Parameters
hDevice | device handle
dataBuffer | user buffer,the buffer size must be greater than or equal to dataLength*channelCount.
dataLength | number of samples per channel
timeOut | timeout time in microsecond
actualReadLength | returns the number of samples per channel actually read
Returns
0 if success or other error code

◆ JY5500_AI_ReadRawData()

JY5500API int JY5500_AI_ReadRawData | ( | JY5500_DeviceHandle | hDevice,
 |  | int * | dataBuffer,
 |  | unsigned int | dataLength,
 |  | int | timeOut,
 |  | unsigned int * | actualReadLength
 | ) |  |

Read AI raw data to user defined data buffer.

For the multi-channel acquisition, the data is interleaved in the order defined by JY5500_AI_EnableChannel.

Parameters
hDevice | device handle
dataBuffer | user buffer, The size of dataBuffer must be greater than or equal to dataLength*channelCount.
dataLength | number of samples per channel
timeOut | timeout time in microsecond
actualReadLength | return the number of samples per channel actually read
Returns
0 if success or other error code

◆ JY5500_AI_ReadRawSinglePoint()

JY5500API int JY5500_AI_ReadRawSinglePoint | ( | JY5500_DeviceHandle | hDevice,
 |  | unsigned int * | readValue,
 |  | int | channelID
 | ) |  |

Read raw single point for each channel to user defined data buffer.

Parameters
hDevice | device handle
readValue | user buffer,the size of readValue must be greater than or equal to channelCount.
channelID | read the specified channelID. when the channelID is -1, read all enabled channels value.
Returns
0 if success or other error code

◆ JY5500_AI_ReadSinglePoint()

JY5500API int JY5500_AI_ReadSinglePoint | ( | JY5500_DeviceHandle | hDevice,
 |  | double * | readValue,
 |  | int | channelID
 | ) |  |

Read single point for each channel to user defined data buffer.

Parameters
hDevice | device handle
readValue | user buffer,the size of readValue must be greater than or equal to channelCount.
channelID | read the specified channelID. when the channelID is -1, read all enabled channels value.
Returns
0 if success or other error code

◆ JY5500_AI_SendSoftTrigger()

JY5500API int JY5500_AI_SendSoftTrigger | ( | JY5500_DeviceHandle | hDevice,
 |  | JY5500_TriggerMode | triggerMode
 | ) |  |

Send the software trigger signal.

Parameters
hDevice | device handle
triggerMode | software trigger mode. Options: start trigger or reference trigger.
Returns
0 if success or other error code

◆ JY5500_AI_SetAnalogEdgeReferenceTrigger()

JY5500API int JY5500_AI_SetAnalogEdgeReferenceTrigger | ( | JY5500_DeviceHandle | hDevice,
 |  | JY5500_AnalogTriggerSource | triggerSource,
 |  | JY5500_AnalogTriggerEdge | triggerEdge,
 |  | double | threshold
 | ) |  |

Set AI analog edge window reference trigger,the triggerSource is defined by enum JY5500_AnalogTriggerSource, the triggerEdge is defined by enum JY5500_AnalogTriggerEdge.

Parameters
hDevice | device handle
triggerSource | AI analog start trigger source,0-31 for 5510 and 5511,0-15 for 5515 and 5516
triggerCondition | AI analog trigger conditions.Options:JY5500_RisingSlope,JY5500_FallingSlope
threshold | threshold
Returns
0 if success or other error code

◆ JY5500_AI_SetAnalogEdgeStartTrigger()

JY5500API int JY5500_AI_SetAnalogEdgeStartTrigger | ( | JY5500_DeviceHandle | hDevice,
 |  | JY5500_AnalogTriggerSource | triggerSource,
 |  | JY5500_AnalogTriggerEdge | triggerEdge,
 |  | double | threshold
 | ) |  |

Set AI analog edge start trigger,the triggerSource is defined by enum JY5500_AnalogTriggerSource, the triggerEdge is defined by enum JY5500_AnalogTriggerEdge.

Parameters
hDevice | device handle
triggerSource | AI analog start trigger source,0-31 for 5510 and 5511,0-15 for 5515 and 5516
triggerCondition | AI analog edge trigger conditions.Options:JY5500_RisingSlope,JY5500_FallingSlope
highThreshold | high threshold
lowThreshold | low threshold
Returns
0 if success or other error code

◆ JY5500_AI_SetAnalogHysteresisReferenceTrigger()

JY5500API int JY5500_AI_SetAnalogHysteresisReferenceTrigger | ( | JY5500_DeviceHandle | hDevice,
 |  | JY5500_AnalogTriggerSource | triggerSource,
 |  | JY5500_AnalogTriggerEdge | triggerEdge,
 |  | double | highThreshold,
 |  | double | lowThreshold
 | ) |  |

Set AI analog hysteresis reference trigger,the triggerSource is defined by enum JY5500_AnalogTriggerSource, the triggerEdge is defined by enum JY5500_AnalogTriggerEdge.

Parameters
hDevice | device handle
triggerSource | AI analog start trigger source,0-31 for 5510 and 5511,0-15 for 5515 and 5516
triggerCondition | AI analog trigger conditions.Options:JY5500_RisingSlope,JY5500_FallingSlope
highThreshold | high threshold
lowThreshold | low threshold
Returns
0 if success or other error code

◆ JY5500_AI_SetAnalogHysteresisStartTrigger()

JY5500API int JY5500_AI_SetAnalogHysteresisStartTrigger | ( | JY5500_DeviceHandle | hDevice,
 |  | JY5500_AnalogTriggerSource | triggerSource,
 |  | JY5500_AnalogTriggerEdge | triggerEdge,
 |  | double | highThreshold,
 |  | double | lowThreshold
 | ) |  |

Set AI analog hysteresis start trigger,the triggerSource is defined by enum JY5500_AnalogTriggerSource, the triggerEdge is defined by enum JY5500_AnalogTriggerEdge.

Parameters
hDevice | device handle
triggerSource | AI analog start trigger source,0-31 for 5510 and 5511,0-15 for 5515 and 5516
triggerCondition | AI analog hysteresis trigger conditions.Options:JY5500_RisingSlope,JY5500_FallingSlope
highThreshold | high threshold
lowThreshold | low threshold
Returns
0 if success or other error code

◆ JY5500_AI_SetAnalogWindowReferenceTrigger()

JY5500API int JY5500_AI_SetAnalogWindowReferenceTrigger | ( | JY5500_DeviceHandle | hDevice,
 |  | JY5500_AnalogTriggerSource | triggerSource,
 |  | JY5500_AnalogWindowCondition | triggerCondition,
 |  | double | highThreshold,
 |  | double | lowThreshold
 | ) |  |

Set AI analog window reference trigger,the triggerSource is defined by enum JY5500_AnalogTriggerSource, the triggerCondition is defined by enum JY5500_AnalogWindowCondition.

Parameters
hDevice | device handle
triggerSource | AI analog window reference trigger source,0-31 for 5510 and 5511,0-15 for 5515 and 5516
triggerCondition | AI analog window trigger conditions.Options:JY5500_Entering,JY5500_Leaving
highThreshold | high threshold
lowThreshold | low threshold
Returns
0 if success or other error code

◆ JY5500_AI_SetAnalogWindowStartTrigger()

JY5500API int JY5500_AI_SetAnalogWindowStartTrigger | ( | JY5500_DeviceHandle | hDevice,
 |  | JY5500_AnalogTriggerSource | triggerSource,
 |  | JY5500_AnalogWindowCondition | triggerCondition,
 |  | double | highThreshold,
 |  | double | lowThreshold
 | ) |  |

Set AI analog window start trigger,the triggerSource is defined by enum JY5500_AnalogTriggerSource, the triggerCondition is defined by enum JY5500_AnalogWindowCondition.

Parameters
hDevice | device handle
triggerSource | AI analog start trigger source,0-31 for 5510 and 5511,0-15 for 5515 and 5516
triggerCondition | AI analog window trigger conditions.Options:JY5500_Entering,JY5500_Leaving
highThreshold | high threshold
lowThreshold | low threshold
Returns
0 if success or other error code

◆ JY5500_AI_SetConvertRate()

JY5500API int JY5500_AI_SetConvertRate | ( | JY5500_DeviceHandle | hDevice,
 |  | double | convertRate,
 |  | double * | actualConvertRate
 | ) |  |

Set convert rate.

convertRate is how fast ADC performs the AD conversion. convertRate = channelCount*sampleRate.

Parameters
hDevice | device handle
scanRate | user set convert rate
actualScanRate | actual convert rate set by this device, which may be different from the desired convertRate.
Returns
0 if success or other error code

◆ JY5500_AI_SetDigitalReferenceTrigger()

JY5500API int JY5500_AI_SetDigitalReferenceTrigger | ( | JY5500_DeviceHandle | hDevice,
 |  | JY5500_DigitalTriggerSource | triggerSource,
 |  | JY5500_DigitalTriggerEdge | triggerEdge
 | ) |  |

Set AI digital reference trigger.the triggerSource is defined by enum JY5500_DigitalTriggerSource, the triggerEdge is defined by enum JY5500_DigitalTriggerEdge.

Parameters
hDevice | device handle
triggerSource | AI digital reference trigger source
triggerEdge | AI digital reference trigger edge. Options: rising or falling edge
Returns
0 if success or other error code

◆ JY5500_AI_SetDigitalStartTrigger()

JY5500API int JY5500_AI_SetDigitalStartTrigger | ( | JY5500_DeviceHandle | hDevice,
 |  | JY5500_DigitalTriggerSource | triggerSource,
 |  | JY5500_DigitalTriggerEdge | triggerEdge
 | ) |  |

Set AI digital start trigger,the triggerSource is defined by enum JY5500_DigitalTriggerSource, the triggerEdge is defined by enum JY5500_DigitalTriggerEdge.

Parameters
hDevice | device handle
triggerSource | AI digital start trigger source
triggerEdge | AI digital start trigger edge. Options: rising or falling edge
Returns
0 if success or other error code

◆ JY5500_AI_SetDSMode()

JY5500API int JY5500_AI_SetDSMode | ( | JY5500_DeviceHandle | hDevice,
 |  | bool | enable,
 |  | JY5500_PowerLineFrequency | powerFrequency
 | ) |  |

Set AI DSMode

Parameters
hDevice | device handle
enable | enable DSMode, true: enable, false: not enable
powerFrequency | AC power Frequency, enum by JY5500_PowerFrequency
Returns
0 if success or other error code

◆ JY5500_AI_SetMode()

JY5500API int JY5500_AI_SetMode | ( | JY5500_DeviceHandle | hDevice,
 |  | JY5500_AI_SampleMode | mode
 | ) |  |

Set AI sampling mode

Parameters
hDevice | device handle
mode | AI sampling mode defined by enum JY5500_AI_SampleMode.
Returns
0 if success or other error code

◆ JY5500_AI_SetPreTriggerSamples()

JY5500API int JY5500_AI_SetPreTriggerSamples | ( | JY5500_DeviceHandle | hDevice,
 |  | unsigned int | preTriggerSamples
 | ) |  |

Set AI pretrigger samples, the samples must greater than 0.

Parameters
hDevice | device handle
preTriggerSamples | AI pretrigger samples, valid only in reference trigger mode.
Returns
0 if success or other error code

◆ JY5500_AI_SetReferenceTriggerType()

JY5500API int JY5500_AI_SetReferenceTriggerType | ( | JY5500_DeviceHandle | hDevice,
 |  | JY5500_AI_TriggerType | triggerType
 | ) |  |

Set AI reference trigger type,the triggerType is defined by enum JY5500_AI_TriggerType

Parameters
hDevice | device handle
triggerType | AI reference trigger type.Options: immediate trigger, software trigger, digital trigger or analog trigger.
Returns
0 if success or other error code

◆ JY5500_AI_SetReTriggerCount()

JY5500API int JY5500_AI_SetReTriggerCount | ( | JY5500_DeviceHandle | hDevice,
 |  | unsigned long long | reTriggerCount
 | ) |  |

Set AI retrigger count.

The device will be triggered reTriggerCount times.

Parameters
hDevice | device handle
reTriggerCount | AI retrigger count
Returns
0 if success or other error code

◆ JY5500_AI_SetSampleClock()

JY5500API int JY5500_AI_SetSampleClock | ( | JY5500_DeviceHandle | hDevice,
 |  | JY5500_ClockSource | clockSource,
 |  | JY5500_ExternalClockTerminal | terminal,
 |  | double | expectedRate
 | ) |  |

Set AI sampling clock source.

the source of the sampling clock defined by enum JY5500_ClockSource. If the clock source is external, external clock terminal and external clock frequency must be configured.

Parameters
hDevice | device handle
clockSource | AI sampling clock source
terminal | external clock terminal
expectedRate | AI external clock frequency
Returns
0 if success or other error code

◆ JY5500_AI_SetSampleRate()

JY5500API int JY5500_AI_SetSampleRate | ( | JY5500_DeviceHandle | hDevice,
 |  | double | sampleRate,
 |  | double * | actualSampleRate
 | ) |  |

Set sampling rate.

The sampling rate is the same for all channels.the API valid only in sample clock source is Internal.

Parameters
hDevice | device handle
sampleRate | AI sampling rate to be set per channel
actualSampleRate | actual sampling rate set by this device,which may be different from the desired sampleRate.
Returns
0 if success or other error code

◆ JY5500_AI_SetSamplesToAcquire()

JY5500API int JY5500_AI_SetSamplesToAcquire | ( | JY5500_DeviceHandle | hDevice,
 |  | unsigned int | sampleToAcquire
 | ) |  |

Set AI samples to acquire for each channel in finite mode.The samples range is 1 to 64M samples / channelCount.

Parameters
hDevice | device handle
sampleToAcquire | AI finite samples to acquire for each channel, samples range:1 to 64M samples / channelCount.
Returns
0 if success or other error code

◆ JY5500_AI_SetStartTriggerType()

JY5500API int JY5500_AI_SetStartTriggerType | ( | JY5500_DeviceHandle | hDevice,
 |  | JY5500_AI_TriggerType | triggerType
 | ) |  |

Set AI start trigger type,the triggerType is defined by enum JY5500_AI_TriggerType.

Parameters
hDevice | device handle
triggerType | AI start trigger type. Options:immediate trigger, software trigger, digital trigger or analog trigger.
Returns
0 if success or other error code

◆ JY5500_AI_Start()

JY5500API int JY5500_AI_Start ( JY5500_DeviceHandle hDevice )

Start AI acquisition.

Parameters
hDevice device handle
Returns
0 if success or other error code

◆ JY5500_AI_Stop()

JY5500API int JY5500_AI_Stop ( JY5500_DeviceHandle hDevice )

Stop AI acquisition.

Parameters
hDevice device handle
Returns
0 if success or other error code

◆ JY5500_AI_WaitUntilDone()

JY5500API int JY5500_AI_WaitUntilDone | ( | JY5500_DeviceHandle | hDevice,
 |  | bool * | done
 | ) |  |

Check if AI acquisition is completed in finite mode.

Parameters
hDevice | device handle
done | true if completed, false if not yet completed.
Returns
0 if success or other error code

◆ JY5500_AO_CheckBufferStatus()

JY5500API int JY5500_AO_CheckBufferStatus | ( | JY5500_DeviceHandle | hDevice,
 |  | unsigned long * | avaliableSamples,
 |  | bool * | overrun
 | ) |  |

Check AO task buffer status.

This API is intended to be compatible with older version drivers. It is recommended to use API JY5500_AO_CheckBufferStatusEx.

Parameters
hDevice | device handle
avaliableSamples | number of AO samples per channel user can write
overrun | true if overflow, false if not overflow.
Returns
0 if success or other error code

◆ JY5500_AO_CheckBufferStatusEx()

JY5500API int JY5500_AO_CheckBufferStatusEx | ( | JY5500_DeviceHandle | hDevice,
 |  | unsigned long * | avaliableSamples,
 |  | unsigned long long * | transferedSamples,
 |  | bool * | overrun
 | ) |  |

Check AO task buffer status.

Parameters
hDevice | device handle
avaliableSamples | number of AO samples per channel user can write
transferedSamples | The number of samples that have been transfered from the device buffer (per channel)
overrun | true if overflow, false if not overflow.
Returns
0 if success or other error code

◆ JY5500_AO_EnableChannel()

JY5500API int JY5500_AO_EnableChannel | ( | JY5500_DeviceHandle | hDevice,
 |  | unsigned int | channelCount,
 |  | unsigned char * | channels,
 |  | double * | lowRegion,
 |  | double * | highRegion
 | ) |  |

Enables AO channels.

Parameters
hDevice | device handle
channelCount | number of channels to be enabled
channels | array[channelCount] containing channel IDs
lowRegion | array[channelCount] of lower limit numbers for each channel,typically in volts.
highRegion | array[channelCount] of higher limit numbers for each channel, typcially in volts.
Returns
0 if success or other error code

◆ JY5500_AO_SendSoftTrigger()

JY5500API int JY5500_AO_SendSoftTrigger ( JY5500_DeviceHandle hDevice )

Send the software trigger signal.

Parameters
hDevice device handle
Returns
0 if success or other error code

◆ JY5500_AO_SetDigitalStartTrigger()

JY5500API int JY5500_AO_SetDigitalStartTrigger | ( | JY5500_DeviceHandle | hDevice,
 |  | JY5500_DigitalTriggerSource | triggerSource,
 |  | JY5500_DigitalTriggerEdge | triggerEdge
 | ) |  |

Set AO digital start trigger,the triggerSource is defined by enum JY5500_DigitalTriggerSource, the triggerEdge is defined by enum JY5500_DigitalTriggerEdge.

Parameters
hDevice | device handle
triggerSource | AO digital start trigger source
triggerEdge | AO digital start trigger edge. Options: rising or falling edge
Returns
0 if success or other error code

◆ JY5500_AO_SetMode()

JY5500API int JY5500_AO_SetMode | ( | JY5500_DeviceHandle | hDevice,
 |  | JY5500_AO_UpdateMode | mode
 | ) |  |

Set AO mode, the mode defined by enum JY5500_AO_UpdateMode.

Parameters
hDevice | device handle
mode | AO output mode.Options: Single,Finite,ContinuousWrapping,ContinuousNoWrapping mode.
Returns
0 if success or other error code

◆ JY5500_AO_SetSampleClock()

JY5500API int JY5500_AO_SetSampleClock | ( | JY5500_DeviceHandle | hDevice,
 |  | JY5500_ClockSource | clockSource,
 |  | JY5500_ExternalClockTerminal | terminal,
 |  | double | expectedRate
 | ) |  |

Set AO sampling clock source.

the source of the sampling clock defined by enum JY5500_ClockSource. If the clock source is external, need to configure external clock terminal and external clock frequency.

Parameters
hDevice | device handle
clockSource | AO sampling clock source
terminal | external clock terminal,defined by enum JY5500_ExternalClockTerminal
expectedRate | external clock frequency
Returns
0 if success or other error code

◆ JY5500_AO_SetSamplesToUpdate()

JY5500API int JY5500_AO_SetSamplesToUpdate | ( | JY5500_DeviceHandle | hDevice,
 |  | unsigned int | sampleToUpdate
 | ) |  |

Set AO samples for each channel in the finite mode.The sample range is from 1 to 32M / channelCount samples.

Parameters
hDevice | device handle
sampleToUpdate | number of AO samples per channel. Data range:1 to 32M / channelCount samples.
Returns
0 if success or other error code

◆ JY5500_AO_SetStartTriggerType()

JY5500API int JY5500_AO_SetStartTriggerType | ( | JY5500_DeviceHandle | hDevice,
 |  | JY5500_AO_TriggerType | triggerType
 | ) |  |

Set AO start trigger type,the triggerType is defined by enum JY5500_AO_TriggerType.

Parameters
hDevice | device handle
triggerType | AO start trigger type. Options: immediate trigger, software trigger, digital trigger .
Returns
0 if success or other error code

◆ JY5500_AO_SetUpdateRate()

JY5500API int JY5500_AO_SetUpdateRate | ( | JY5500_DeviceHandle | hDevice,
 |  | double | updateRate,
 |  | double * | actualUpdateRate
 | ) |  |

Set AO update rate for each channel.

Parameters
hDevice | device handle
updateRate | AO update rate to be set per channel
actualUpdateRate | AO update rate actually set. The actual update rate set by this device,which may be different from the desired updata rate.
Returns
0 if success or other error code

◆ JY5500_AO_Start()

JY5500API int JY5500_AO_Start ( JY5500_DeviceHandle hDevice )

Start digital signal output.

Parameters
hDevice device handle
Returns
0 if success or other error code

◆ JY5500_AO_Stop()

JY5500API int JY5500_AO_Stop ( JY5500_DeviceHandle hDevice )

Stop analog signal output.

Parameters
hDevice device handle
Returns
0 if success or other error code

◆ JY5500_AO_WaitUntilDone()

JY5500API int JY5500_AO_WaitUntilDone | ( | JY5500_DeviceHandle | hDevice,
 |  | bool * | done,
 |  | int | timeOut
 | ) |  |

Check AO finite output is complete.

Parameters
hDevice | device handle
done | true if completed, false if not yet completed.
timeOut | timeout time in microsecond, this parament not valid in current version
Returns
0 if success or other error code

◆ JY5500_AO_WriteData()

JY5500API int JY5500_AO_WriteData | ( | JY5500_DeviceHandle | hDevice,
 |  | double * | dataBuffer,
 |  | unsigned int | dataLength,
 |  | int | timeOut,
 |  | unsigned int * | actualWriteLength
 | ) |  |

AO writes data.The data is interleaved in the buffer the order defined by JY5500_AO_EnableChannel.

Parameters
hDevice | device handle
dataBuffer | user buffer of output data.The buffer size must be greater than or equal to dataLength*number of enabled channels.
dataLength | total number of output data for all channels
timeOut | timeout time in microsecond
actualWriteLength | the number of samples per channel actually write
Returns
0 if success or other error code

◆ JY5500_AO_WriteRawData()

JY5500API int JY5500_AO_WriteRawData | ( | JY5500_DeviceHandle | hDevice,
 |  | short * | dataBuffer,
 |  | unsigned int | dataLength,
 |  | int | timeOut,
 |  | unsigned int * | actualWriteLength
 | ) |  |

AO write raw data.The data is interleaved in the buffer in channel order for multi-channel.

Parameters
hDevice | device handle
dataBuffer | user buffer, the buffer size must be greater than or equal to dataLength*number of enabled channels.
dataLength | total number of output data for all channels
timeOut | timeout time in microsecond
actualWriteLength | the number of samples per channel actually write
Returns
0 if success or other error code

◆ JY5500_AO_WriteRawSinglePoint()

JY5500API int JY5500_AO_WriteRawSinglePoint | ( | JY5500_DeviceHandle | hDevice,
 |  | unsigned short * | writeValues,
 |  | int | channelID
 | ) |  |

AO write single point raw data to the defined channel by channelID, if channelID == -1, write all enable channel.

Parameters
hDevice | device handle
writeValues | write value for each enable channel,when channelID == -1 the writeValue length must equal to channelCount
channelID | defined channel, if channelID == -1, write all enable channel one data
Returns
0 if success or other error code

◆ JY5500_AO_WriteSinglePoint()

JY5500API int JY5500_AO_WriteSinglePoint | ( | JY5500_DeviceHandle | hDevice,
 |  | double * | writeValues,
 |  | int | channelID
 | ) |  |

AO write single point data to the defined channel by channelID, if channelID == -1, write all enable channel one data.

Parameters
hDevice | device handle
writeValues | write value for each enable channel,when channelID == -1 the writeValue length must equal to channelCount
channelID | defined channel, if channelID == -1, write all enable channel one data
Returns
0 if success or other error code

◆ JY5500_CI_CheckBufferStatus()

JY5500API int JY5500_CI_CheckBufferStatus | ( | JY5500_DeviceHandle | hDevice,
 |  | unsigned int | channel,
 |  | unsigned long long * | avaliableSamples,
 |  | bool * | overrun
 | ) |  |

Check CI task buffer status.

This API is intended to be compatible with older version drivers. It is recommended to use API JY5500_CI_CheckBufferStatusEx.

Parameters
hDevice | device handle
channel | counter input channel
avaliableSamples | number of samples that the device buffer can read
overrun | true if overflow, false if not overflow.
Returns
0 if success or other error code

◆ JY5500_CI_CheckBufferStatusEx()

JY5500API int JY5500_CI_CheckBufferStatusEx | ( | JY5500_DeviceHandle | hDevice,
 |  | unsigned int | channel,
 |  | unsigned long long * | avaliableSamples,
 |  | unsigned long long * | transferedSamples,
 |  | bool * | overrun
 | ) |  |

Check CI task buffer status.

Parameters
hDevice | device handle
channel | counter input channel
avaliableSamples | number of samples that the device buffer can read
transferedSamples | The number of samples that have been transfered from the device buffer (per channel)
overrun | true if overflow, false if not overflow.
Returns
0 if success or other error code

◆ JY5500_CI_EnableChannel()

JY5500API int JY5500_CI_EnableChannel | ( | JY5500_DeviceHandle | hDevice,
 |  | unsigned int | channel
 | ) |  |

Enables CI channel.There are 4 counter,from 0 to 3.

Parameters
hDevice | device handle
channel | counter input channel
Returns
0 if success or other error code

◆ JY5500_CI_ReadCountValues()

JY5500API int JY5500_CI_ReadCountValues | ( | JY5500_DeviceHandle | hDevice,
 |  | unsigned int | channel,
 |  | unsigned int * | countValues,
 |  | unsigned int | dataLength,
 |  | int | timeOut,
 |  | unsigned int * | actualReadLength
 | ) |  |

Counter reads the count values, this API is supprot CI Type ：JY5500_CI_EdgeCount、JY5500_CI_EncoderX1、 JY5500_CI_EncoderX2 、 JY5500_CI_EncoderX4 、JY5500_CI_EncoderTwoPulse.

Parameters
hDevice | device handle
channel | counter input channel
countValues | user buffer,the buffer size must be greater than or equal to dataLength
dataLength | read data length
timeOut | timeout time in microsecond
actualReadLength | return value, the actual length of the data read.
Returns
0 if success or other error code

◆ JY5500_CI_ReadMeasureValues()

JY5500API int JY5500_CI_ReadMeasureValues | ( | JY5500_DeviceHandle | hDevice,
 |  | unsigned int | channel,
 |  | double * | measureValues1,
 |  | double * | measureValues2,
 |  | unsigned int | dataLength,
 |  | int | timeOut,
 |  | unsigned int * | actualReadLength
 | ) |  |

Counter reads the measured values, this API only support CI Type for JY5500_CI_Measure_EdgeSeparation JY5500_CI_Measure_Pulse JY5500_CI_Measure_Frequency JY5500_CI_Measure_Period for JY5500_CI_Measure_EdgeSeparation type, the measureValues1 is the Gate signel to the Aux signal interval, the measureValues2 is the Aux signel to the Gate signal interval, the unit is s.

for JY5500_CI_Measure_Pulse type, the measureValues1 is the Low level signal time, the measureValues2 is the Highe level signal time, the unit is s. for JY5500_CI_Measure_Frequency type, the measureValues1 is signal frequency, the unit is Hz. for JY5500_CI_Measure_Period type, the measureValues2 is signal period, the unit is s. The JY5500_CI_Measure_Period type and JY5500_CI_Measure_Frequency type is same time measurement, user need to read both measurements simultaneously.

Parameters
hDevice | device handle
channel | counter input channel
measureValues | user buffer.The buffer size must be greater than or equal to dataLength
dataLength | read data length
timeOut | measure timeout time in microsecond
actualReadLength | reture the actual length of the data read
Returns
0 if success or other error code

◆ JY5500_CI_ReadSingleCountValue()

JY5500API int JY5500_CI_ReadSingleCountValue | ( | JY5500_DeviceHandle | hDevice,
 |  | unsigned int | channel,
 |  | unsigned int * | countValue
 | ) |  |

Counter reads a single count value, this API supports the CI Type: JY5500_CI_EdgeCount、JY5500_CI_EncoderX1、 JY5500_CI_EncoderX2 、 JY5500_CI_EncoderX4 、JY5500_CI_EncoderTwoPulse.

Parameters
hDevice | device handle
channel | counter input channel. An integer counter number, eg, 0 for counter 0.
countValue | return the current count value of counter.
Returns
0 if success or other error code

◆ JY5500_CI_ReadSingleMeasureValue()

JY5500API int JY5500_CI_ReadSingleMeasureValue | ( | JY5500_DeviceHandle | hDevice,
 |  | unsigned int | channel,
 |  | double * | measureValue1,
 |  | double * | measureValue2,
 |  | int | timeOut
 | ) |  |

Reads a single counter measurement as follows.

for JY5500_CI_Measure_EdgeSeparation type, measureValues1 is the Gate signel to the Aux signal interval, the measureValues2 is the Aux signel to the Gate signal interval, the unit is in s. for JY5500_CI_Measure_Pulse type, measureValues1 is the Low level signal time, the measureValues2 is the high level signal time, the unit is in second. for JY5500_CI_Measure_Frequency type, measureValues1 is signal frequency in Hz, measureValue2 has no meaning. for JY5500_CI_Measure_Period type, measureValues2 is signal period in second; measureValue1 has no meaning.

Parameters
hDevice | device handle
channel | Counter input channel
measureValue1 | current measure value of counter
measureValue2 | current measure value of counter
timeOut | timeout time in microsecond
Returns
0 if success or other error code

◆ JY5500_CI_SendSoftTrigger()

JY5500API int JY5500_CI_SendSoftTrigger | ( | JY5500_DeviceHandle | hDevice,
 |  | int | channel
 | ) |  |

Send the software trigger signal for CI.

Parameters
hDevice | device handle
channel | counter input channel
Returns
0 if success or other error code

◆ JY5500_CI_SetCounterParament()

JY5500API int JY5500_CI_SetCounterParament | ( | JY5500_DeviceHandle | hDevice,
 |  | unsigned int | channel,
 |  | int | initCount,
 |  | JY5500_CountDirection | countDirection
 | ) |  |

Set CI count parameter

Parameters
hDevice | device handle
channel | counter input channel
initCount | counter initial value
countDirection | counting direction of the counter defined by enum JY5500_CountDirection
Returns
0 if success or other error code

◆ JY5500_CI_SetCounterType()

JY5500API int JY5500_CI_SetCounterType | ( | JY5500_DeviceHandle | hDevice,
 |  | unsigned int | channel,
 |  | JY5500_CI_MeasureType | measureType
 | ) |  |

Set CI measure type

Parameters
hDevice | device handle
channel | counter input channel
measureType | measure type. defined by enum JY5500_CI_MeasureType
Returns
0 if success or other error code

◆ JY5500_CI_SetDigitalStartTrigger()

JY5500API int JY5500_CI_SetDigitalStartTrigger | ( | JY5500_DeviceHandle | hDevice,
 |  | int | channel,
 |  | JY5500_DigitalTriggerSource | triggerSource,
 |  | JY5500_DigitalTriggerEdge | triggerEdge
 | ) |  |

Set CI digital start trigger.the triggerSource is defined by enum JY5500_DigitalTriggerSource, the triggerEdge is defined by enum JY5500_DigitalTriggerEdge.

Parameters
hDevice | device handle
channel | counter input channel
triggerSource | CI digital start trigger source
triggerEdge | CI digital start trigger edge. Options: rising or falling edge.
Returns
0 if success or other error code

◆ JY5500_CI_SetEdgeCountEvent()

JY5500API int JY5500_CI_SetEdgeCountEvent | ( | JY5500_DeviceHandle | hDevice,
 |  | unsigned int | channel,
 |  | JY5500_CI_CounterEventSignalIdleState | idleState,
 |  | unsigned int | threshold
 | ) |  |

Set the counter threshold, and when the count reaches this threshold, output a single pulse at the output terminal

Parameters
hDevice | device handle
channel | counter input channel
idleState | output terminal idle state
threshold | threshold
Returns
0 if success or other error code

◆ JY5500_CI_SetMode()

JY5500API int JY5500_CI_SetMode | ( | JY5500_DeviceHandle | hDevice,
 |  | unsigned int | channel,
 |  | JY5500_CI_SampleMode | mode
 | ) |  |

Set counter input mode, the mode is defined by enum JY5500_CI_SampleMode.

Parameters
hDevice | device handle
channel | counter input channel
mode | counter input mode, Options: single,finite,continuous.
Returns
0 if success or other error code

◆ JY5500_CI_SetPauseTriggerLevel()

JY5500API int JY5500_CI_SetPauseTriggerLevel | ( | JY5500_DeviceHandle | hDevice,
 |  | unsigned int | channel,
 |  | bool | enable,
 |  | JY5500_LevelState | pauseTriggerActiveLevel
 | ) |  |

Config CI pause trigger.

Parameters
hDevice | Device handle
channel | Counter channel
enable | Enable pasue trigger
pauseTriggerActiveLevel | Pause trigger active level.
Returns
Succeed: 0 , Error: !=0

◆ JY5500_CI_SetSampleClock()

JY5500API int JY5500_CI_SetSampleClock | ( | JY5500_DeviceHandle | hDevice,
 |  | unsigned int | channel,
 |  | JY5500_CI_SampleClock | clock,
 |  | JY5500_ExternalClockTerminal | terminal,
 |  | double | rate
 | ) |  |

Set counter input sampling clock source.

If the clockType is internal, user need to define sampleRate, if the clockType is JY5500_CI_ImplicitClk, the sample rate determine by the measuer signal.

Parameters
hDevice | device handle
channel | counter input channel
clockType | counter input clock type. Option: internal clock 、 implicit clock、external clock.
terminal | external clock terminal,defined by enum JY5500_ExternalClockTerminal
rate | external clock frequency,when clockType is implicit clock or external clock. when clockType is Internal clock, the rate is internal sample rate
Returns
0 if success or other error code

◆ JY5500_CI_SetSamplesToAcquire()

JY5500API int JY5500_CI_SetSamplesToAcquire | ( | JY5500_DeviceHandle | hDevice,
 |  | unsigned int | channel,
 |  | unsigned int | samplesToAcquire
 | ) |  |

Set samples to acquire in finite mode.The samples range is 1 to 4M.

Parameters
hDevice | device handle
channel | counter input channel
samplesToAcquire | CI finite samples to acquire, samples range:1 to 4M samples.
Returns
0 if success or other error code

◆ JY5500_CI_SetSignalReverse()

JY5500API int JY5500_CI_SetSignalReverse | ( | JY5500_DeviceHandle | hDevice,
 |  | unsigned int | channel,
 |  | int | signalReverse
 | ) |  |

Set the Signal Reverse terminal.

Parameters
hDevice | device handle
channel | counter input channel
signalReverse | The lower 4bit is valid. 0bit represents Source, 1bit represents Gate, 2bit represents Aux, and 3bit represents Extclk
Returns
0 if success or other error code

◆ JY5500_CI_SetStartTriggerType()

JY5500API int JY5500_CI_SetStartTriggerType | ( | JY5500_DeviceHandle | hDevice,
 |  | int | channel,
 |  | JY5500_CIO_TriggerType | triggerTyp
 | ) |  |

Set CI start trigger type,the triggerType is defined by enum JY5500_CI_TriggerType.

Parameters
hDevice | device handle
channel | counter input channel
triggerType | CI start trigger type. Options: immediate trigger, software trigger, digital trigger.
Returns
0 if success or other error code

◆ JY5500_CI_SetTimeBase()

JY5500API int JY5500_CI_SetTimeBase | ( | JY5500_DeviceHandle | hDevice,
 |  | int | channel,
 |  | JY5500_CountTimeBase | timeBase
 | ) |  |

Set counter input time base,the time base defined by enum JY5500_CountTimeBase.

Parameters
hDevice | device handle
channel | counter input channel
timeBase | counter timebase
Returns
0 if success or other error code

◆ JY5500_CI_SetZReloadEnabled()

JY5500API int JY5500_CI_SetZReloadEnabled | ( | JY5500_DeviceHandle | hDevice,
 |  | unsigned int | channel,
 |  | bool | zReloadEnabled
 | ) |  |

Set the Z signal enable in Encoder mode.

Parameters
hDevice | device handle
channel | counter input channel
zReloadEnabled | enable z signal. True: enabled; False: disabled.Valid only under encoder mode.
Returns
0 if success or other error code

◆ JY5500_CI_Start()

JY5500API int JY5500_CI_Start | ( | JY5500_DeviceHandle | hDevice,
 |  | unsigned int | channel
 | ) |  |

Start Counter input.

Parameters
hDevice | device handle
channel | counter input channel
Returns
0 if success or other error code

◆ JY5500_CI_Stop()

JY5500API int JY5500_CI_Stop | ( | JY5500_DeviceHandle | hDevice,
 |  | unsigned int | channel
 | ) |  |

Stop Counter input.

Parameters
hDevice | device handle
channel | counter input channel
Returns
0 if success or other error code

◆ JY5500_Close()

JY5500API int JY5500_Close ( JY5500_DeviceHandle hDevice )

Close this 5500 device.

Parameters
hDevice device handle
Returns
0 if success or other error code

◆ JY5500_CO_CheckBufferStatus()

JY5500API int JY5500_CO_CheckBufferStatus | ( | JY5500_DeviceHandle | hDevice,
 |  | unsigned int | channel,
 |  | unsigned long * | avaliableSamples,
 |  | bool * | overrun
 | ) |  |

Check CO task buffer status.This API is intended to be compatible with older version drivers.

It is recommended to use API JY5500_CO_CheckBufferStatusEx.

Parameters
hDevice | device handle
channel | counter output channel
avaliableSamples | number of CO samples per channel user can write
overrun | true if overflow, false if not overflow.
Returns
0 if success or other error code

◆ JY5500_CO_CheckBufferStatusEx()

JY5500API int JY5500_CO_CheckBufferStatusEx | ( | JY5500_DeviceHandle | hDevice,
 |  | unsigned int | channel,
 |  | unsigned long * | avaliableSamples,
 |  | unsigned long long * | transferedSamples,
 |  | bool * | overrun
 | ) |  |

Check CO task buffer status.

Parameters
hDevice | device handle
channel | counter output channel
avaliableSamples | number of CO samples per channel user can write
transferedSamples | The number of samples that have been transfered from the device buffer (per channel)
overrun | true if overflow, false if not overflow.
Returns
0 if success or other error code

◆ JY5500_CO_CheckCounterStatus()

JY5500API int JY5500_CO_CheckCounterStatus | ( | JY5500_DeviceHandle | hDevice,
 |  | unsigned int | channel,
 |  | unsigned int * | pulseTransfered,
 |  | bool * | underflow
 | ) |  |

Check counter output status.

Parameters
hDevice | device handle
channel | counter output channel
pulseTransfered | The number of pulse that have been transfered
overrun | true:overflow, false:not overflow.
Returns
0 if success or other error code

◆ JY5500_CO_EnableChannel()

JY5500API int JY5500_CO_EnableChannel | ( | JY5500_DeviceHandle | hDevice,
 |  | unsigned int | channel
 | ) |  |

Enabled counter output channel.

Parameters
hDevice | device handle
channel | counter output channel
Returns
0 if success or other error code

◆ JY5500_CO_SendSoftTrigger()

JY5500API int JY5500_CO_SendSoftTrigger | ( | JY5500_DeviceHandle | hDevice,
 |  | int | channel
 | ) |  |

Send the software trigger signal.

Parameters
hDevice | device handle
channel | counter channel
Returns
0 if success or other error code

◆ JY5500_CO_SetCounterParament()

JY5500API int JY5500_CO_SetCounterParament | ( | JY5500_DeviceHandle | hDevice,
 |  | unsigned int | channel,
 |  | int | pulseCount,
 |  | JY5500_CO_IdleState | IdleState,
 |  | double | delay
 | ) |  |

Set CO parameter.

Parameters
hDevice | device handle
channel | counter output channel
pulseCount | counter output pulse number, if pulseCount = -1 ,the device always responds to output until the user stops it.
IdleState | counter output idle state
delay | counter output delay, unit:s. There are five ticks of the timebase fixed delay in counter internal, so the total delay(s) = delay + (5 / timebase)
Returns
0 if success or other error code

◆ JY5500_CO_SetDigitalStartTrigger()

JY5500API int JY5500_CO_SetDigitalStartTrigger | ( | JY5500_DeviceHandle | hDevice,
 |  | int | channel,
 |  | JY5500_DigitalTriggerSource | triggerSource,
 |  | JY5500_DigitalTriggerEdge | triggerEdge
 | ) |  |

Set CO digital start trigger,the triggerSource is defined by enum JY5500_DigitalTriggerSource, the triggerEdge is defined by enum JY5500_DigitalTriggerEdge.

Parameters
hDevice | device handle
channel | counter channel
triggerSource | CO digital start trigger source
triggerEdge | CO digital start trigger edge. Options: rising or falling edge.
Returns
0 if success or other error code

◆ JY5500_CO_SetFrequency()

JY5500API int JY5500_CO_SetFrequency | ( | JY5500_DeviceHandle | hDevice,
 |  | unsigned int | channel,
 |  | unsigned int | highTicks,
 |  | unsigned int | lowTicks
 | ) |  |

Set counter output pulse frequency

Parameters
hDevice | device handle
channel | counter output channel
highTicks | the number of ticks for the high pulse, timebase is 200MHz.
lowTicks | the number of ticks for the low pulse, timebase is 200MHz.
Returns
0 if success or other error code

◆ JY5500_CO_SetFrequencyOnFly()

JY5500API int JY5500_CO_SetFrequencyOnFly | ( | JY5500_DeviceHandle | hDevice,
 |  | unsigned int | channel,
 |  | unsigned int | highTicks,
 |  | unsigned int | lowTicks
 | ) |  |

Set the output pulse frequency of the counter in real time.

After the output starts, you can call this interface to modify the pulse frequency in real time.

Parameters
hDevice | device handle
channel | counter output channel
highTicks | the number of ticks for the high pulse, timebase is 200MHz.
lowTicks | the number of ticks for the low pulse, timebase is 200MHz.
Returns
0 if success or other error code

◆ JY5500_CO_SetMode()

JY5500API int JY5500_CO_SetMode | ( | JY5500_DeviceHandle | hDevice,
 |  | unsigned int | channel,
 |  | JY5500_CO_OUTMode | mode
 | ) |  |

Set counter output mode, the mode defined by enum JY5500_CO_UpdateMode.

Parameters
hDevice | device handle
mode | CO mode.Options: Single,Finite,ContinuousWrapping,ContinuousNoWrapping mode.
Returns
0 if success or other error code

◆ JY5500_CO_SetSamplesToUpdate()

JY5500API int JY5500_CO_SetSamplesToUpdate | ( | JY5500_DeviceHandle | hDevice,
 |  | unsigned int | channel,
 |  | unsigned int | samplesToUpdate
 | ) |  |

Set CO samples for each channel in the finite mode.The sample range is from 1 to 4M samples.

Parameters
hDevice | device handle
channel | counter output channel
sampleToUpdate | number of CO samples per channel. Data range:1 to 4M samples.
Returns
0 if success or other error code

◆ JY5500_CO_SetStartTriggerType()

JY5500API int JY5500_CO_SetStartTriggerType | ( | JY5500_DeviceHandle | hDevice,
 |  | int | channel,
 |  | JY5500_CIO_TriggerType | triggerTyp
 | ) |  |

Set CO start trigger type,the triggerType is defined by enum JY5500_AI_TriggerType

Parameters
hDevice | device handle
channel | counter channel
triggerType | CO start trigger type. Options:immediate trigger, software trigger, digital trigger.
Returns
0 if success or other error code

◆ JY5500_CO_SetTimeBase()

JY5500API int JY5500_CO_SetTimeBase | ( | JY5500_DeviceHandle | hDevice,
 |  | int | channel,
 |  | JY5500_CountTimeBase | timeBase
 | ) |  |

Set CO timebase source

Parameters
hDevice | device handle
channel | counter channel
timeBase | counter time base source.defined by emun JY5500_CountTimeBase.Options:JY5500_TimeBase_200M
Returns
0 if success or other error code

◆ JY5500_CO_Start()

JY5500API int JY5500_CO_Start | ( | JY5500_DeviceHandle | hDevice,
 |  | unsigned int | channel
 | ) |  |

Start counter output.

Parameters
hDevice | device handle
channel | counter output channel
Returns
0 if success or other error code

◆ JY5500_CO_Stop()

JY5500API int JY5500_CO_Stop | ( | JY5500_DeviceHandle | hDevice,
 |  | unsigned int | channel
 | ) |  |

Stop counter output.

Parameters
hDevice | device handle
channel | counter output channel
Returns
0 if success or other error code

◆ JY5500_CO_WaitUntilDone()

JY5500API int JY5500_CO_WaitUntilDone | ( | JY5500_DeviceHandle | hDevice,
 |  | unsigned int | channel,
 |  | bool * | done
 | ) |  |

Check counter output complete status.

Parameters
hDevice | device handle
channel | counter output channel
done | true :counter output complete, false:counter output not complete
Returns
0 if success or other error code

◆ JY5500_CO_WriteData()

JY5500API int JY5500_CO_WriteData | ( | JY5500_DeviceHandle | hDevice,
 |  | int | channel,
 |  | unsigned int * | dataBuffer,
 |  | unsigned int | dataLength,
 |  | int | timeOut,
 |  | unsigned int * | actualWriteLength
 | ) |  |

CO write data.One sampling point consists of three datas, high level ticks, low level ticks, and number of pulses.

Parameters
hDevice | device handle
channel | counter output channel
dataBuffer | user buffer, the buffer size must be greater than or equal to dataLength*3.
dataLength | length of pulse output
timeOut | timeout time in microsecond
actualWriteLength | the number of samples per channel actually write
Returns
0 if success or other error code

◆ JY5500_DI_AddLines()

JY5500API int JY5500_DI_AddLines | ( | JY5500_DeviceHandle | hDevice,
 |  | unsigned int * | port,
 |  | unsigned int | portCount
 | ) |  |

Enabled DI channels.

Parameters
hDevice | device handle
port | array[portCount] containing port IDs
portCount | number of ports to be enabled
Returns
0 if success or other error code

◆ JY5500_DI_CheckBufferStatus()

JY5500API int JY5500_DI_CheckBufferStatus | ( | JY5500_DeviceHandle | hDevice,
 |  | unsigned long long * | avaliableSamples,
 |  | bool * | overrun
 | ) |  |

Check DI device buffer status.This API is intended to be compatible with older version drivers.

It is recommended to use API JY5500_DI_CheckBufferStatusEx.

Parameters
hDevice | device handle
avaliableSamples | number of samples per channel in the device buffer
overrun | true if overflow, false if not overflow.
Returns
0 if success or other error code

◆ JY5500_DI_CheckBufferStatusEx()

JY5500API int JY5500_DI_CheckBufferStatusEx | ( | JY5500_DeviceHandle | hDevice,
 |  | unsigned long long * | avaliableSamples,
 |  | unsigned long long * | transferedSamples,
 |  | bool * | overrun
 | ) |  |

Check DI device buffer status.

Parameters
hDevice | device handle
avaliableSamples | number of samples per channel in the device buffer
transferedSamples | The number of samples that have been transfered from the device buffer (per channel)
overrun | true if overflow, false if not overflow.
Returns
0 if success or other error code

◆ JY5500_DI_ReadData()

JY5500API int JY5500_DI_ReadData | ( | JY5500_DeviceHandle | hDevice,
 |  | unsigned int * | dataBuffer,
 |  | unsigned int | dataLength,
 |  | int | timeOut,
 |  | unsigned int * | actualReadLength
 | ) |  |

Read DI data.

The data type is uint. There are 4 ports(0~3)for 5510 and 5511, 3 ports(0~2)for 5515 and 5516, Each port has 8 lines, from 0 to 7. There are a total of 32 lines from 0 to 31. Each bit from low to high represents one line.

Parameters
hDevice | device handle
dataBuffer | user buffer, the size of dataBuffer must be greater than or equal to dataLength.
dataLength | number of samples per channel
timeOut | timeout time in microsecond
actualReadLength | the actual length of the data read
Returns
0 if success or other error code

◆ JY5500_DI_ReadSinglePoint()

JY5500API int JY5500_DI_ReadSinglePoint | ( | JY5500_DeviceHandle | hDevice,
 |  | bool * | readValues,
 |  | int | portID
 | ) |  |

read single data from a single port by portID defined.if the portID == -1,read all port data.The data type is bool, one bool defined one line status.

Parameters
hDevice | device handle
readValues | read the specified port values,the readValues Length must equal to 8, and the order is form line 0 to line 7. when the portID is -1, read all enabled ports values,the readValues Length must equal to 8*portCount(In function JY5500_DI_AddLines defined), and the values store in the add order of ports, in one port, the order is form line 0 to line 7.
portID | port number
Returns
0 if success or other error code

◆ JY5500_DI_ReadSinglePoint_U64()

JY5500API int JY5500_DI_ReadSinglePoint_U64 | ( | JY5500_DeviceHandle | hDevice,
 |  | unsigned long long * | readValue
 | ) |  |

read single data from a single port by portID defined.if the portID == -1,read all port data.The data type is unsigned long long,There are 6 ports, from 0 to 5.

Each port has 8 lines, from 0 to 7. There are a total of 48 lines from 0 to 47. Each bit from low to high represents one line.

Parameters
hDevice device handle
readValue read the specified port values,each bit from low to high represents one line..
Returns
0 if success or other error code

◆ JY5500_DI_ReadSinglePoint_U8()

JY5500API int JY5500_DI_ReadSinglePoint_U8 | ( | JY5500_DeviceHandle | hDevice,
 |  | unsigned char * | readValues,
 |  | int | portID
 | ) |  |

read single data from a single port by portID defined.if the portID == -1,read all port data.The data type is unsigned char, one char defined one port status.

Parameters
hDevice | device handle
readValues | read the specified port values,the char bit 1 to 7 defined the port line 0 to line 7. when the portID is -1, read all enabled ports values,the readValues Length must equal to portCount(In function JY5500_DI_AddLines defined), and the values store in the add order of ports.
portID | port number
Returns
0 if success or other error code

◆ JY5500_DI_SendSoftTrigger()

JY5500API int JY5500_DI_SendSoftTrigger | ( | JY5500_DeviceHandle | hDevice,
 |  | JY5500_TriggerMode | triggerMode
 | ) |  |

Send the software trigger signal.

Parameters
hDevice | device handle
triggerMode | software trigger mode. Options: start trigger or reference trigger
Returns
0 if success or other error code

◆ JY5500_DI_SetDigitalReferenceTrigger()

JY5500API int JY5500_DI_SetDigitalReferenceTrigger | ( | JY5500_DeviceHandle | hDevice,
 |  | JY5500_DigitalTriggerSource | triggerSource,
 |  | JY5500_DigitalTriggerEdge | triggerEdge
 | ) |  |

Set AI digital reference trigger,the triggerSource is defined by enum JY5500_DigitalTriggerSource, the triggerEdge is defined by enum JY5500_DigitalTriggerEdge.

Parameters
hDevice | device handle
triggerSource | DI reference trigger source
triggerEdge | DI reference to the trigger edge. Options: rising or falling edge
Returns
0 if success or other error code

◆ JY5500_DI_SetDigitalStartTrigger()

JY5500API int JY5500_DI_SetDigitalStartTrigger | ( | JY5500_DeviceHandle | hDevice,
 |  | JY5500_DigitalTriggerSource | triggerSource,
 |  | JY5500_DigitalTriggerEdge | triggerEdge
 | ) |  |

Set DI digital start trigger,the triggerSource is defined by enum JY5500_DigitalTriggerSource, the triggerEdge is defined by enum JY5500_DigitalTriggerEdge.

Parameters
hDevice | device handle
triggerSource | DI digital start trigger source
triggerEdge | DI digital start trigger edge. Options: rising or falling edge
Returns
0 if success or other error code

◆ JY5500_DI_SetMode()

JY5500API int JY5500_DI_SetMode | ( | JY5500_DeviceHandle | hDevice,
 |  | JY5500_DI_SampleMode | mode
 | ) |  |

Set DI sampling mode.The mode defined by enum JY5500_DI_SampleMode.

Parameters
hDevice | device handle
mode | DI sampling mode.Options: single,finite,continuous.
Returns
0 if success or other error code

◆ JY5500_DI_SetPreTriggerSamples()

JY5500API int JY5500_DI_SetPreTriggerSamples | ( | JY5500_DeviceHandle | hDevice,
 |  | unsigned int | preTriggerSamples
 | ) |  |

Set DI pretrigger samples, the samples must greater than 0.

Parameters
hDevice | device handle
preTriggerSamples | DI pretrigger samples, valid only in reference trigger mode.
Returns
0 if success or other error code

◆ JY5500_DI_SetReferenceTriggerType()

JY5500API int JY5500_DI_SetReferenceTriggerType | ( | JY5500_DeviceHandle | hDevice,
 |  | JY5500_DI_TriggerType | triggerType
 | ) |  |

Set DI reference trigger type,the triggerType is defined by enum JY5500_DI_TriggerType.

Parameters
hDevice | device handle
triggerType | DI reference trigger type. Options: immediate trigger, software trigger, digital trigger or analog trigger.
Returns
0 if success or other error code

◆ JY5500_DI_SetSampleClock()

JY5500API int JY5500_DI_SetSampleClock | ( | JY5500_DeviceHandle | hDevice,
 |  | JY5500_ClockSource | clockSource,
 |  | JY5500_ExternalClockTerminal | terminal,
 |  | double | expectedRate
 | ) |  |

Set DI sampling clock source.

the source of the sampling clock defined by enum JY5500_ClockSource If the clock source is external, need to configure external clock terminal and external clock frequency..

Parameters
hDevice | device handle
clockSource | DI sampling clock source
terminal | external clock terminal,defined by enum JY5500_ExternalClockTerminal.
expectedRate | external clock frequency
Returns
0 if success or other error code

◆ JY5500_DI_SetSampleRate()

JY5500API int JY5500_DI_SetSampleRate | ( | JY5500_DeviceHandle | hDevice,
 |  | double | sampleRate,
 |  | double * | actualSampleRate
 | ) |  |

Set DI sampling rate.

The sampling rate is the same for all channels.

Parameters
hDevice | device handle
sampleRate | DI sampling rate to be set per channel
actualSampleRate | actually set DI sampling rate.actual sampling rate set by this device,which may be different from the desired sampleRate.
Returns
0 if success or other error code

◆ JY5500_DI_SetSamplesToAcquire()

JY5500API int JY5500_DI_SetSamplesToAcquire | ( | JY5500_DeviceHandle | hDevice,
 |  | int | samplesToAcquire
 | ) |  |

Set DI samples to acquire for each channel in finite mode.The samples range is 1 to 16M samples.

Parameters
hDevice | device handle
samplesToAcquire | DI finite samples to acquire for each channelsamples range:1 to 16M samples
Returns
0 if success or other error code

◆ JY5500_DI_SetStartTriggerType()

JY5500API int JY5500_DI_SetStartTriggerType | ( | JY5500_DeviceHandle | hDevice,
 |  | JY5500_DI_TriggerType | triggerType
 | ) |  |

Set DI start trigger type,the triggerType is defined by enum JY5500_DI_TriggerType

Parameters
hDevice | device handle
triggerType | DI start trigger type. Options: immediate trigger, software trigger, digital trigger.
Returns
0 if success or other error code

◆ JY5500_DI_Start()

JY5500API int JY5500_DI_Start ( JY5500_DeviceHandle hDevice )

Start DI acquisition.

Parameters
hDevice device handle
Returns
0 if success or other error code

◆ JY5500_DI_Stop()

JY5500API int JY5500_DI_Stop ( JY5500_DeviceHandle hDevice )

Stop DI acquisition.

Parameters
hDevice device handle
Returns
0 if success or other error code

◆ JY5500_DI_WaitUntilDone()

JY5500API int JY5500_DI_WaitUntilDone | ( | JY5500_DeviceHandle | hDevice,
 |  | bool * | done
 | ) |  |

Check if DI acquisition is completed in finite mode.

Parameters
hDevice | device handle
done | true if completed, false if not yet completed.
Returns
0 if success or other error code

◆ JY5500_DisableAICalibration()

JY5500API int JY5500_DisableAICalibration | ( | JY5500_DeviceHandle | hDevice,
 |  | bool | DisableCalibration
 | ) |  |

Disable AI calibration coefficient, default enable calibration coefficient

Parameters
hDevice | device handle
DisableCalibration | true if disabled, false if not disabled.
Returns
0 if success or other error code

◆ JY5500_DisableAOCalibration()

JY5500API int JY5500_DisableAOCalibration | ( | JY5500_DeviceHandle | hDevice,
 |  | bool | DisableCalibration
 | ) |  |

Disable AO calibration coefficient, default enable calibration coefficient

Parameters
hDevice | device handle
DisableCalibration | true if disabled, false if not disabled.
Returns
0 if success or other error code

◆ JY5500_DisconnectSignalRouting()

JY5500API int JY5500_DisconnectSignalRouting | ( | JY5500_DeviceHandle | hDevice,
 |  | JY5500_Signal_Destination | destination
 | ) |  |

Disconnect an established routing.

Parameters
hDevice | device handle
destination | destination of the signal defined by enum JY5500_Signal_Destination
Returns
0 if success or other error code

◆ JY5500_DO_AddLines()

JY5500API int JY5500_DO_AddLines | ( | JY5500_DeviceHandle | hDevice,
 |  | unsigned int * | port,
 |  | unsigned int | portCount
 | ) |  |

Enabled DO channels

Parameters
hDevice | device handle
port | array[portCount] containing port IDs.
portCount | number of ports to be enabled
Returns
0 if success or other error code

◆ JY5500_DO_CheckBufferStatus()

JY5500API int JY5500_DO_CheckBufferStatus | ( | JY5500_DeviceHandle | hDevice,
 |  | unsigned long * | avaliableSamples,
 |  | bool * | overrun
 | ) |  |

Check DO device buffer status.This API is intended to be compatible with older version drivers.

It is recommended to use API JY5500_DO_CheckBufferStatusEx.

Parameters
hDevice | device handle
avaliableSamples | number of samples that the buffer can write
overrun | true if overflow, false if not overflow.
Returns
0 if success or other error code

◆ JY5500_DO_CheckBufferStatusEx()

JY5500API int JY5500_DO_CheckBufferStatusEx | ( | JY5500_DeviceHandle | hDevice,
 |  | unsigned long * | avaliableSamples,
 |  | unsigned long long * | transferedSamples,
 |  | bool * | overrun
 | ) |  |

Check DO device buffer status.

Parameters
hDevice | device handle
avaliableSamples | number of samples that the buffer can write
transferedSamples | The number of samples that have been transfered from the device buffer (per channel)
overrun | true if overflow, false if not overflow.
Returns
0 if success or other error code

◆ JY5500_DO_SendSoftTrigger()

JY5500API int JY5500_DO_SendSoftTrigger ( JY5500_DeviceHandle hDevice )

Send the software trigger signal.

Parameters
hDevice device handle
Returns
0 if success or other error code

◆ JY5500_DO_SetDigitalStartTrigger()

JY5500API int JY5500_DO_SetDigitalStartTrigger | ( | JY5500_DeviceHandle | hDevice,
 |  | JY5500_DigitalTriggerSource | triggerSource,
 |  | JY5500_DigitalTriggerEdge | triggerEdge
 | ) |  |

Set DO digital start trigger,the triggerSource is defined by enum JY5500_DigitalTriggerSource, the triggerEdge is defined by enum JY5500_DigitalTriggerEdge.

Parameters
hDevice | device handle
triggerSource | DO digital start trigger source
triggerEdge | DO digital start trigger edge. Options: rising or falling edge.
Returns
0 if success or other error code

◆ JY5500_DO_SetMode()

JY5500API int JY5500_DO_SetMode | ( | JY5500_DeviceHandle | hDevice,
 |  | JY5500_DO_UpdateMode | mode
 | ) |  |

Set digital signal output mode, the mode defined by enum JY5500_AO_UpdateMode.

Parameters
hDevice | device handle
mode | DO output mode.Options: Single,Finite,ContinuousWrapping,ContinuousNoWrapping mode.
Returns
0 if success or other error code

◆ JY5500_DO_SetSampleClock()

JY5500API int JY5500_DO_SetSampleClock | ( | JY5500_DeviceHandle | hDevice,
 |  | JY5500_ClockSource | clockSource,
 |  | JY5500_ExternalClockTerminal | terminal,
 |  | double | expectedRate
 | ) |  |

Set DO sampling clock source.

the source of the sampling clock defined by enum JY5500_ClockSource. If the clock source is external, need to configure external clock terminal and external clock frequency.

Parameters
hDevice | device handle
clockSource | DO sampling clock source
terminal | external terminal, defined by enum JY5500_ExternalClockTerminal
expectedRate | DO external clock frequency

◆ JY5500_DO_SetSamplesToUpdate()

JY5500API int JY5500_DO_SetSamplesToUpdate | ( | JY5500_DeviceHandle | hDevice,
 |  | int | samplesToUpdate
 | ) |  |

Set digital signal output samples for each channel in finite mode.The samples range is 1 to 16M samples.

Parameters
hDevice | device handle
sampleToUpdate | DO finite output samples, data range:1 to 16M sample.
Returns
0 if success or other error code

◆ JY5500_DO_SetStartTriggerType()

JY5500API int JY5500_DO_SetStartTriggerType | ( | JY5500_DeviceHandle | hDevice,
 |  | JY5500_DO_TriggerType | triggerType
 | ) |  |

Set DO start trigger type,the triggerType is defined by enum JY5500_DO_TriggerType.

Parameters
hDevice | device handle
triggerType | DO start trigger type. Options: immediate trigger, software trigger, digital trigger.
Returns
0 if success or other error code

◆ JY5500_DO_SetUpdateRate()

JY5500API int JY5500_DO_SetUpdateRate | ( | JY5500_DeviceHandle | hDevice,
 |  | double | sampleRate,
 |  | double * | actualSampleRate
 | ) |  |

Set DO update rate.The update rate is the same for all channels.

Parameters
hDevice | device handle
sampleRate | DO update rate to be set per channel
actualSampleRate | actually set DO update rate,actual update rate set by this device,which may be different from the desired updata rate.
Returns
0 if success or other error code

◆ JY5500_DO_Start()

JY5500API int JY5500_DO_Start ( JY5500_DeviceHandle hDevice )

Start digital signal output.

Parameters
hDevice device handle
Returns
0 if success or other error code

◆ JY5500_DO_Stop()

JY5500API int JY5500_DO_Stop ( JY5500_DeviceHandle hDevice )

Stop digital signal output.

Parameters
hDevice device handle
Returns
0 if success or other error code

◆ JY5500_DO_WaitUntilDone()

JY5500API int JY5500_DO_WaitUntilDone | ( | JY5500_DeviceHandle | hDevice,
 |  | bool * | done,
 |  | int | timeOut
 | ) |  |

Check finite digital signal output is complete.

Parameters
hDevice | device handle
done | true if completed, false if not yet completed.
timeOut | timeout time in microsecond,this parament not valid in current version
Returns
0 if success or other error code

◆ JY5500_DO_WriteData()

JY5500API int JY5500_DO_WriteData | ( | JY5500_DeviceHandle | hDevice,
 |  | unsigned int * | dataBuffer,
 |  | unsigned int | dataLength,
 |  | int | timeOut,
 |  | unsigned int * | actualWriteLength
 | ) |  |

DO write data.The data type is uint.

There are 4 ports(0~3)for 5510 and 5511, 3 ports(0~2)for 5515 and 5516, Each port has 8 lines, from 0 to 7. There are a total of 32 lines from 0 to 31. Each bit from low to high represents one line.

Parameters
hDevice | device handle
dataBuffer | user buffer,the buffer size must be greater than or equal to dataLength.
dataLength | number of samples per channel
timeOut | timeout time in microsecond
actualWriteLength | Return value, the actual length of the data write
Returns
0 if success or other error code

◆ JY5500_DO_WriteSinglePoint()

JY5500API int JY5500_DO_WriteSinglePoint | ( | JY5500_DeviceHandle | hDevice,
 |  | bool * | writeValues,
 |  | int | portID
 | ) |  |

write single data to the port by portID defined.if the portID == -1,write all port data.

Parameters
hDevice | device handle
writeValues | write the specified port values,the writeValues Length must equal to 8, and the order is form line 0 to line 7. when the portID is -1, write all enabled ports values,the writeValues Length must equal to 8*portCount(In function JY5500_DO_AddLines defined), and the values store in the add order of ports, in one port, the order is form line 0 to line 7.
portID | port number
Returns
0 if success or other error code

◆ JY5500_DO_WriteSinglePoint_U64()

JY5500API int JY5500_DO_WriteSinglePoint_U64 | ( | JY5500_DeviceHandle | hDevice,
 |  | unsigned long long | writeValues
 | ) |  |

write single data to the port by portID defined.if the portID == -1,write all port data.The data type is unsigned long long,There are 6 ports, from 0 to 5.

Each port has 8 lines, from 0 to 7. There are a total of 48 lines from 0 to 47. Each bit from low to high represents one line.

Parameters
hDevice device handle
writeValue write the specified port values,each bit from low to high represents one line..
Returns
0 if success or other error code

◆ JY5500_DO_WriteSinglePoint_U8()

JY5500API int JY5500_DO_WriteSinglePoint_U8 | ( | JY5500_DeviceHandle | hDevice,
 |  | unsigned char * | writeValue,
 |  | int | portID
 | ) |  |

write single data to the port by portID defined.if the portID == -1,write all port data.The data type is unsigned char, one char defined one port status.

Parameters
hDevice | device handle
writeValue | write the specified port values,the char bit 1 to 7 defined the port line 0 to line 7. when the portID is -1, write all enabled ports values,the readValues Length must equal to portCount(In function JY5500_DI_AddLines defined), and the values store in the add order of ports.
portID | port number
Returns
0 if success or other error code

◆ JY5500_GetDeviceFPGATemperature()

JY5500API int JY5500_GetDeviceFPGATemperature | ( | JY5500_DeviceHandle | hDevice,
 |  | double * | temperature
 | ) |  |

Get FPGA temperature reading of the device in Celsius degree.

Parameters
hDev | device handle
temp | returned temperature value in Celsius degree
Returns
0 if success or other error code

◆ JY5500_GetDeviceID()

JY5500API int JY5500_GetDeviceID | ( | JY5500_DeviceHandle | hDevice,
 |  | int * | deviceID
 | ) |  |

Obtain the device ID.

The 5500 is a series of boards. The PXIe-5510 device ID is Ox5510, PXIe-5511 device ID is Ox5511. The PXIe-5515 device ID is Ox5515, PXIe-5516 device ID is Ox5516. The PCIe-5510 device ID is Ox370A, PCIe-5511 device ID is Ox370B. The PCIe-5515 device ID is Ox370F, PCIe-5516 device ID is Ox3710. The USB-5510 device ID is OxB510, USB-5511 device ID is OxB511. The USB-5515 device ID is OxB515, USB-5516 device ID is OxB516.

Parameters
hDevice | device handle
deviceID | device ID
Returns
0 if success or other error code

◆ JY5500_GetDeviceSerialNumber()

JY5500API int JY5500_GetDeviceSerialNumber | ( | JY5500_DeviceHandle | hDevice,
 |  | char * | serialNumber,
 |  | int | length
 | ) |  |

Obtain the device serialNumber

Parameters
hDevice | device handle
serialNumber | Pointer to a buffer receiving the serial number. The length of the serial number is 10.
length | serial Number length ,length is 10
Returns
0 if success or other error code

◆ JY5500_GetDeviceTemperature()

JY5500API int JY5500_GetDeviceTemperature | ( | JY5500_DeviceHandle | hDevice,
 |  | double * | temperature
 | ) |  |

Get Device temperature reading of the device in Celsius degree.

Parameters
hDev | device handle
temp | returned temperature value in Celsius degree
Returns
0 if success or other error code

◆ JY5500_Open()

JY5500API int JY5500_Open | ( | int | slotNumber,
 |  | JY5500_DeviceHandle * | hDevice
 | ) |  |

Open the 5500 series devices using the slot number or the device serial number.

PXIe slot number is predefined by the PXIe chassis. PCIe slot number is defined by the DIP switch. The device serial number is defined by the system starting from 0. It's your responsibility to know the number. For a single board, the serial number is 0.

Parameters
slotNumber | slot number or device serial number
hDevice | device handle. All other functions uses hDevice to represent this device.
Returns
0 if success or other error code

◆ JY5500_OpenByName()

JY5500API int JY5500_OpenByName | ( | const char * | cardName,
 |  | JY5500_DeviceHandle * | hDevice
 | ) |  |

Open this 5500 series devices using the device alias name which is set by JYTEK utility JYDM.

You can change the name using JYDM.

Parameters
cardName | device alias name
hDevice | device handle
Returns
0 if success or other error code

◆ JY5500_SetDeviceReferenceClock()

JY5500API int JY5500_SetDeviceReferenceClock | ( | JY5500_DeviceHandle | hDevice,
 |  | JY5500_ReferenceClock | clkSource
 | ) |  |

Set ReferenceClock for the device.There are two ReferenceClock, Internal 25MHz from this device or 100MHz from the PXIe chassis.

PCIe device only supports internal 25MHz reference clock.

Parameters
hDevice | device handle
clkSource | ReferenceClock source defined by enum JY5500_ReferenceClock
Returns
0 if success or other error code

◆ JY5500_SetDeviceStatusLed()

JY5500API int JY5500_SetDeviceStatusLed | ( | JY5500_DeviceHandle | hDevice,
 |  | bool | enable,
 |  | unsigned int | frequency
 | ) |  |

Control Front Panel Status Led

Parameters
hDevice | device handle
enable | enable front panel status led blink, true: blink, false: not blink
frequency | when enable is ture, the led blink speed by frequency define
Returns
0 if success or other error code

◆ JY5500_SetPFIFilter()

JY5500API int JY5500_SetPFIFilter | ( | JY5500_DeviceHandle | hDevice,
 |  | int | line,
 |  | bool | filterEnabled,
 |  | int | minPulseWidth,
 |  | int * | actualMinPulseWidth
 | ) |  |

Set the filter for the specified PFI

Parameters
hDevice | device handle
line | define PFI Line
filterEnabled | filter enable
minPulseWidth | The minimum pulse width below which pulses will be filtered out by the filter, unit:ns
actualMinPulseWidth | Actual minimum pulse width be set, unit:ns
Returns
0 if success or other error code

◆ JY5500_SignalRouting()

JY5500API int JY5500_SignalRouting | ( | JY5500_DeviceHandle | hDevice,
 |  | JY5500_Signal_Source | source,
 |  | JY5500_Signal_Destination | destination
 | ) |  |

Route a singal from source to destination.

Both source and destination are defined by the corresponding enum JY5500_Signal_Source and JY5500_Signal_Destination. One source signal may be routed to multiple destinations.

Parameters
hDevice | device handle
source | source of the signal defined by enum JY5500_Signal_Source
destination | destination of the signal defined by enum JY5500_Signal_Destination
Returns
0 if success or other error code


5500 C++ Programming Manual: D:/5500 Directory Reference

  • D:
  • 5500
5500 Directory Reference

Directories

directory Cpp


5500 C++ Programming Manual: D: Directory Reference

  • D:
D: Directory Reference

Directories

directory 5500


5500 C++ Programming Manual: File List

File List
Here is a list of all files with brief descriptions:
[detail level 1234]
▼ D: |
▼ 5500 |
▼ Cpp |
JY5500.h | @SectionBegin JY5500 FileHead


5500 C++ Programming Manual: File Members

Here is a list of all file members with links to the files they belong to:

- j -

  • JY5500_50_Hz : JY5500.h
  • JY5500_60_Hz : JY5500.h
  • JY5500_AI_Analog : JY5500.h
  • JY5500_AI_CheckBufferStatus() : JY5500.h
  • JY5500_AI_CheckBufferStatusEx() : JY5500.h
  • JY5500_AI_Continuous : JY5500.h
  • JY5500_AI_Diff : JY5500.h
  • JY5500_AI_Digital : JY5500.h
  • JY5500_AI_EnableChannel() : JY5500.h
  • JY5500_AI_Finite : JY5500.h
  • JY5500_AI_Immediately : JY5500.h
  • JY5500_AI_NRSE : JY5500.h
  • JY5500_AI_ReadData() : JY5500.h
  • JY5500_AI_ReadRawData() : JY5500.h
  • JY5500_AI_ReadRawSinglePoint() : JY5500.h
  • JY5500_AI_ReadSinglePoint() : JY5500.h
  • JY5500_AI_ReferenceTrig : JY5500.h
  • JY5500_AI_RSE : JY5500.h
  • JY5500_AI_SampleClock : JY5500.h
  • JY5500_AI_SampleMode : JY5500.h
  • JY5500_AI_SendSoftTrigger() : JY5500.h
  • JY5500_AI_SetAnalogEdgeReferenceTrigger() : JY5500.h
  • JY5500_AI_SetAnalogEdgeStartTrigger() : JY5500.h
  • JY5500_AI_SetAnalogHysteresisReferenceTrigger() : JY5500.h
  • JY5500_AI_SetAnalogHysteresisStartTrigger() : JY5500.h
  • JY5500_AI_SetAnalogWindowReferenceTrigger() : JY5500.h
  • JY5500_AI_SetAnalogWindowStartTrigger() : JY5500.h
  • JY5500_AI_SetConvertRate() : JY5500.h
  • JY5500_AI_SetDigitalReferenceTrigger() : JY5500.h
  • JY5500_AI_SetDigitalStartTrigger() : JY5500.h
  • JY5500_AI_SetDSMode() : JY5500.h
  • JY5500_AI_SetMode() : JY5500.h
  • JY5500_AI_SetPreTriggerSamples() : JY5500.h
  • JY5500_AI_SetReferenceTriggerType() : JY5500.h
  • JY5500_AI_SetReTriggerCount() : JY5500.h
  • JY5500_AI_SetSampleClock() : JY5500.h
  • JY5500_AI_SetSampleRate() : JY5500.h
  • JY5500_AI_SetSamplesToAcquire() : JY5500.h
  • JY5500_AI_SetStartTriggerType() : JY5500.h
  • JY5500_AI_Single : JY5500.h
  • JY5500_AI_Soft : JY5500.h
  • JY5500_AI_Start() : JY5500.h
  • JY5500_AI_StartTrig : JY5500.h
  • JY5500_AI_Stop() : JY5500.h
  • JY5500_AI_Terminal : JY5500.h
  • JY5500_AI_TriggerType : JY5500.h
  • JY5500_AI_WaitUntilDone() : JY5500.h
  • JY5500_AnalogTriggerEdge : JY5500.h
  • JY5500_AnalogTriggerSource : JY5500.h
  • JY5500_AnalogWindowCondition : JY5500.h
  • JY5500_AO_CheckBufferStatus() : JY5500.h
  • JY5500_AO_CheckBufferStatusEx() : JY5500.h
  • JY5500_AO_ContinuousNoWrapping : JY5500.h
  • JY5500_AO_ContinuousWrapping : JY5500.h
  • JY5500_AO_Digital : JY5500.h
  • JY5500_AO_EnableChannel() : JY5500.h
  • JY5500_AO_Finite : JY5500.h
  • JY5500_AO_Immediately : JY5500.h
  • JY5500_AO_SampleClock : JY5500.h
  • JY5500_AO_SendSoftTrigger() : JY5500.h
  • JY5500_AO_SetDigitalStartTrigger() : JY5500.h
  • JY5500_AO_SetMode() : JY5500.h
  • JY5500_AO_SetSampleClock() : JY5500.h
  • JY5500_AO_SetSamplesToUpdate() : JY5500.h
  • JY5500_AO_SetStartTriggerType() : JY5500.h
  • JY5500_AO_SetUpdateRate() : JY5500.h
  • JY5500_AO_Single : JY5500.h
  • JY5500_AO_Soft : JY5500.h
  • JY5500_AO_Start() : JY5500.h
  • JY5500_AO_StartTrig : JY5500.h
  • JY5500_AO_Stop() : JY5500.h
  • JY5500_AO_TriggerType : JY5500.h
  • JY5500_AO_UpdateMode : JY5500.h
  • JY5500_AO_WaitUntilDone() : JY5500.h
  • JY5500_AO_WriteData() : JY5500.h
  • JY5500_AO_WriteRawData() : JY5500.h
  • JY5500_AO_WriteRawSinglePoint() : JY5500.h
  • JY5500_AO_WriteSinglePoint() : JY5500.h
  • JY5500_Channel_0 : JY5500.h
  • JY5500_Channel_1 : JY5500.h
  • JY5500_Channel_10 : JY5500.h
  • JY5500_Channel_11 : JY5500.h
  • JY5500_Channel_12 : JY5500.h
  • JY5500_Channel_13 : JY5500.h
  • JY5500_Channel_14 : JY5500.h
  • JY5500_Channel_15 : JY5500.h
  • JY5500_Channel_16 : JY5500.h
  • JY5500_Channel_17 : JY5500.h
  • JY5500_Channel_18 : JY5500.h
  • JY5500_Channel_19 : JY5500.h
  • JY5500_Channel_2 : JY5500.h
  • JY5500_Channel_20 : JY5500.h
  • JY5500_Channel_21 : JY5500.h
  • JY5500_Channel_22 : JY5500.h
  • JY5500_Channel_23 : JY5500.h
  • JY5500_Channel_24 : JY5500.h
  • JY5500_Channel_25 : JY5500.h
  • JY5500_Channel_26 : JY5500.h
  • JY5500_Channel_27 : JY5500.h
  • JY5500_Channel_28 : JY5500.h
  • JY5500_Channel_29 : JY5500.h
  • JY5500_Channel_3 : JY5500.h
  • JY5500_Channel_30 : JY5500.h
  • JY5500_Channel_31 : JY5500.h
  • JY5500_Channel_4 : JY5500.h
  • JY5500_Channel_5 : JY5500.h
  • JY5500_Channel_6 : JY5500.h
  • JY5500_Channel_7 : JY5500.h
  • JY5500_Channel_8 : JY5500.h
  • JY5500_Channel_9 : JY5500.h
  • JY5500_CI_0_SampleClock : JY5500.h
  • JY5500_CI_0_StartTrig : JY5500.h
  • JY5500_CI_1_SampleClock : JY5500.h
  • JY5500_CI_1_StartTrig : JY5500.h
  • JY5500_CI_2_SampleClock : JY5500.h
  • JY5500_CI_2_StartTrig : JY5500.h
  • JY5500_CI_3_SampleClock : JY5500.h
  • JY5500_CI_3_StartTrig : JY5500.h
  • JY5500_CI_CheckBufferStatus() : JY5500.h
  • JY5500_CI_CheckBufferStatusEx() : JY5500.h
  • JY5500_CI_Continuous : JY5500.h
  • JY5500_CI_Count_Down : JY5500.h
  • JY5500_CI_Count_External : JY5500.h
  • JY5500_CI_Count_Up : JY5500.h
  • JY5500_CI_CounterEventSignalIdleState : JY5500.h
  • JY5500_CI_CounterEventSignalIdleState_High : JY5500.h
  • JY5500_CI_CounterEventSignalIdleState_Low : JY5500.h
  • JY5500_CI_EdgeCount : JY5500.h
  • JY5500_CI_EnableChannel() : JY5500.h
  • JY5500_CI_EncoderTwoPulse : JY5500.h
  • JY5500_CI_EncoderX1 : JY5500.h
  • JY5500_CI_EncoderX2 : JY5500.h
  • JY5500_CI_EncoderX4 : JY5500.h
  • JY5500_CI_ExternalClock : JY5500.h
  • JY5500_CI_Finite : JY5500.h
  • JY5500_CI_ImplicitClock : JY5500.h
  • JY5500_CI_InternalClock : JY5500.h
  • JY5500_CI_Measure_EdgeSeparation : JY5500.h
  • JY5500_CI_Measure_FrequencyOrPeriod : JY5500.h
  • JY5500_CI_Measure_PulseWidth : JY5500.h
  • JY5500_CI_MeasureType : JY5500.h
  • JY5500_CI_ReadCountValues() : JY5500.h
  • JY5500_CI_ReadMeasureValues() : JY5500.h
  • JY5500_CI_ReadSingleCountValue() : JY5500.h
  • JY5500_CI_ReadSingleMeasureValue() : JY5500.h
  • JY5500_CI_SampleClock : JY5500.h
  • JY5500_CI_SampleMode : JY5500.h
  • JY5500_CI_SendSoftTrigger() : JY5500.h
  • JY5500_CI_SetCounterParament() : JY5500.h
  • JY5500_CI_SetCounterType() : JY5500.h
  • JY5500_CI_SetDigitalStartTrigger() : JY5500.h
  • JY5500_CI_SetEdgeCountEvent() : JY5500.h
  • JY5500_CI_SetMode() : JY5500.h
  • JY5500_CI_SetPauseTriggerLevel() : JY5500.h
  • JY5500_CI_SetSampleClock() : JY5500.h
  • JY5500_CI_SetSamplesToAcquire() : JY5500.h
  • JY5500_CI_SetSignalReverse() : JY5500.h
  • JY5500_CI_SetStartTriggerType() : JY5500.h
  • JY5500_CI_SetTimeBase() : JY5500.h
  • JY5500_CI_SetZReloadEnabled() : JY5500.h
  • JY5500_CI_Single : JY5500.h
  • JY5500_CI_Start() : JY5500.h
  • JY5500_CI_Stop() : JY5500.h
  • JY5500_CIO_Digital : JY5500.h
  • JY5500_CIO_Immediately : JY5500.h
  • JY5500_CIO_Soft : JY5500.h
  • JY5500_CIO_TriggerType : JY5500.h
  • JY5500_ClockSource : JY5500.h
  • JY5500_Close() : JY5500.h
  • JY5500_CO_0_Output : JY5500.h
  • JY5500_CO_0_StartTrig : JY5500.h
  • JY5500_CO_1_Output : JY5500.h
  • JY5500_CO_1_StartTrig : JY5500.h
  • JY5500_CO_2_Output : JY5500.h
  • JY5500_CO_2_StartTrig : JY5500.h
  • JY5500_CO_3_Output : JY5500.h
  • JY5500_CO_3_StartTrig : JY5500.h
  • JY5500_CO_CheckBufferStatus() : JY5500.h
  • JY5500_CO_CheckBufferStatusEx() : JY5500.h
  • JY5500_CO_CheckCounterStatus() : JY5500.h
  • JY5500_CO_ContinuousNoWrapping : JY5500.h
  • JY5500_CO_ContinuousWrapping : JY5500.h
  • JY5500_CO_EnableChannel() : JY5500.h
  • JY5500_CO_Finite : JY5500.h
  • JY5500_CO_HighLevel : JY5500.h
  • JY5500_CO_IdleState : JY5500.h
  • JY5500_CO_LowLevel : JY5500.h
  • JY5500_CO_OUTMode : JY5500.h
  • JY5500_CO_SendSoftTrigger() : JY5500.h
  • JY5500_CO_SetCounterParament() : JY5500.h
  • JY5500_CO_SetDigitalStartTrigger() : JY5500.h
  • JY5500_CO_SetFrequency() : JY5500.h
  • JY5500_CO_SetFrequencyOnFly() : JY5500.h
  • JY5500_CO_SetMode() : JY5500.h
  • JY5500_CO_SetSamplesToUpdate() : JY5500.h
  • JY5500_CO_SetStartTriggerType() : JY5500.h
  • JY5500_CO_SetTimeBase() : JY5500.h
  • JY5500_CO_Single : JY5500.h
  • JY5500_CO_Start() : JY5500.h
  • JY5500_CO_Stop() : JY5500.h
  • JY5500_CO_WaitUntilDone() : JY5500.h
  • JY5500_CO_WriteData() : JY5500.h
  • JY5500_CountDirection : JY5500.h
  • JY5500_CountTimeBase : JY5500.h
  • JY5500_DeviceHandle : JY5500.h
  • JY5500_DI_AddLines() : JY5500.h
  • JY5500_DI_CheckBufferStatus() : JY5500.h
  • JY5500_DI_CheckBufferStatusEx() : JY5500.h
  • JY5500_DI_Continuous : JY5500.h
  • JY5500_DI_Digital : JY5500.h
  • JY5500_DI_Finite : JY5500.h
  • JY5500_DI_Immediately : JY5500.h
  • JY5500_DI_ReadData() : JY5500.h
  • JY5500_DI_ReadSinglePoint() : JY5500.h
  • JY5500_DI_ReadSinglePoint_U64() : JY5500.h
  • JY5500_DI_ReadSinglePoint_U8() : JY5500.h
  • JY5500_DI_ReferenceTrig : JY5500.h
  • JY5500_DI_SampleClock : JY5500.h
  • JY5500_DI_SampleMode : JY5500.h
  • JY5500_DI_SendSoftTrigger() : JY5500.h
  • JY5500_DI_SetDigitalReferenceTrigger() : JY5500.h
  • JY5500_DI_SetDigitalStartTrigger() : JY5500.h
  • JY5500_DI_SetMode() : JY5500.h
  • JY5500_DI_SetPreTriggerSamples() : JY5500.h
  • JY5500_DI_SetReferenceTriggerType() : JY5500.h
  • JY5500_DI_SetSampleClock() : JY5500.h
  • JY5500_DI_SetSampleRate() : JY5500.h
  • JY5500_DI_SetSamplesToAcquire() : JY5500.h
  • JY5500_DI_SetStartTriggerType() : JY5500.h
  • JY5500_DI_Single : JY5500.h
  • JY5500_DI_Soft : JY5500.h
  • JY5500_DI_Start() : JY5500.h
  • JY5500_DI_StartTrig : JY5500.h
  • JY5500_DI_Stop() : JY5500.h
  • JY5500_DI_TriggerType : JY5500.h
  • JY5500_DI_WaitUntilDone() : JY5500.h
  • JY5500_DigitalTriggerEdge : JY5500.h
  • JY5500_DigitalTriggerSource : JY5500.h
  • JY5500_DisableAICalibration() : JY5500.h
  • JY5500_DisableAOCalibration() : JY5500.h
  • JY5500_DisconnectSignalRouting() : JY5500.h
  • JY5500_DO_AddLines() : JY5500.h
  • JY5500_DO_CheckBufferStatus() : JY5500.h
  • JY5500_DO_CheckBufferStatusEx() : JY5500.h
  • JY5500_DO_ContinuousNoWrapping : JY5500.h
  • JY5500_DO_ContinuousWrapping : JY5500.h
  • JY5500_DO_Digital : JY5500.h
  • JY5500_DO_Finite : JY5500.h
  • JY5500_DO_Immediately : JY5500.h
  • JY5500_DO_SampleClock : JY5500.h
  • JY5500_DO_SendSoftTrigger() : JY5500.h
  • JY5500_DO_SetDigitalStartTrigger() : JY5500.h
  • JY5500_DO_SetMode() : JY5500.h
  • JY5500_DO_SetSampleClock() : JY5500.h
  • JY5500_DO_SetSamplesToUpdate() : JY5500.h
  • JY5500_DO_SetStartTriggerType() : JY5500.h
  • JY5500_DO_SetUpdateRate() : JY5500.h
  • JY5500_DO_Single : JY5500.h
  • JY5500_DO_Soft : JY5500.h
  • JY5500_DO_Start() : JY5500.h
  • JY5500_DO_StartTrig : JY5500.h
  • JY5500_DO_Stop() : JY5500.h
  • JY5500_DO_TriggerType : JY5500.h
  • JY5500_DO_UpdateMode : JY5500.h
  • JY5500_DO_WaitUntilDone() : JY5500.h
  • JY5500_DO_WriteData() : JY5500.h
  • JY5500_DO_WriteSinglePoint() : JY5500.h
  • JY5500_DO_WriteSinglePoint_U64() : JY5500.h
  • JY5500_DO_WriteSinglePoint_U8() : JY5500.h
  • JY5500_ECLK : JY5500.h
  • JY5500_Entering : JY5500.h
  • JY5500_ExternalClock : JY5500.h
  • JY5500_ExternalClockTerminal : JY5500.h
  • JY5500_Falling : JY5500.h
  • JY5500_FallingSlope : JY5500.h
  • JY5500_GetDeviceFPGATemperature() : JY5500.h
  • JY5500_GetDeviceID() : JY5500.h
  • JY5500_GetDeviceSerialNumber() : JY5500.h
  • JY5500_GetDeviceTemperature() : JY5500.h
  • JY5500_HighLevel : JY5500.h
  • JY5500_Inter_AI_ReferenceTrig : JY5500.h
  • JY5500_Inter_AI_SampleClock : JY5500.h
  • JY5500_Inter_AI_StartTrig : JY5500.h
  • JY5500_Inter_AO_SampleClock : JY5500.h
  • JY5500_Inter_AO_StartTrig : JY5500.h
  • JY5500_Inter_CI0_SampleClock : JY5500.h
  • JY5500_Inter_CI1_SampleClock : JY5500.h
  • JY5500_Inter_CI2_SampleClock : JY5500.h
  • JY5500_Inter_CI3_SampleClock : JY5500.h
  • JY5500_Inter_CI_0_StartTrig : JY5500.h
  • JY5500_Inter_CI_1_StartTrig : JY5500.h
  • JY5500_Inter_CI_2_StartTrig : JY5500.h
  • JY5500_Inter_CI_3_StartTrig : JY5500.h
  • JY5500_Inter_CO_0_Output : JY5500.h
  • JY5500_Inter_CO_0_Output_Trig : JY5500.h
  • JY5500_Inter_CO_0_StartTrig : JY5500.h
  • JY5500_Inter_CO_1_Output : JY5500.h
  • JY5500_Inter_CO_1_Output_Trig : JY5500.h
  • JY5500_Inter_CO_1_StartTrig : JY5500.h
  • JY5500_Inter_CO_2_Output : JY5500.h
  • JY5500_Inter_CO_2_Output_Trig : JY5500.h
  • JY5500_Inter_CO_2_StartTrig : JY5500.h
  • JY5500_Inter_CO_3_Output : JY5500.h
  • JY5500_Inter_CO_3_Output_Trig : JY5500.h
  • JY5500_Inter_CO_3_StartTrig : JY5500.h
  • JY5500_Inter_DI_ReferenceTrig : JY5500.h
  • JY5500_Inter_DI_SampleClock : JY5500.h
  • JY5500_Inter_DI_StartTrig : JY5500.h
  • JY5500_Inter_DO_SampleClock : JY5500.h
  • JY5500_Inter_DO_StartTrig : JY5500.h
  • JY5500_Internal : JY5500.h
  • JY5500_InternalClock : JY5500.h
  • JY5500_Leaving : JY5500.h
  • JY5500_LevelState : JY5500.h
  • JY5500_LowLevel : JY5500.h
  • JY5500_Open() : JY5500.h
  • JY5500_OpenByName() : JY5500.h
  • JY5500_PFI0 : JY5500.h
  • JY5500_PFI0_OUT : JY5500.h
  • JY5500_PFI1 : JY5500.h
  • JY5500_PFI10 : JY5500.h
  • JY5500_PFI10_OUT : JY5500.h
  • JY5500_PFI11 : JY5500.h
  • JY5500_PFI11_OUT : JY5500.h
  • JY5500_PFI12 : JY5500.h
  • JY5500_PFI12_OUT : JY5500.h
  • JY5500_PFI13 : JY5500.h
  • JY5500_PFI13_OUT : JY5500.h
  • JY5500_PFI14 : JY5500.h
  • JY5500_PFI14_OUT : JY5500.h
  • JY5500_PFI15 : JY5500.h
  • JY5500_PFI15_OUT : JY5500.h
  • JY5500_PFI1_OUT : JY5500.h
  • JY5500_PFI2 : JY5500.h
  • JY5500_PFI2_OUT : JY5500.h
  • JY5500_PFI3 : JY5500.h
  • JY5500_PFI3_OUT : JY5500.h
  • JY5500_PFI4 : JY5500.h
  • JY5500_PFI4_OUT : JY5500.h
  • JY5500_PFI5 : JY5500.h
  • JY5500_PFI5_OUT : JY5500.h
  • JY5500_PFI6 : JY5500.h
  • JY5500_PFI6_OUT : JY5500.h
  • JY5500_PFI7 : JY5500.h
  • JY5500_PFI7_OUT : JY5500.h
  • JY5500_PFI8 : JY5500.h
  • JY5500_PFI8_OUT : JY5500.h
  • JY5500_PFI9 : JY5500.h
  • JY5500_PFI9_OUT : JY5500.h
  • JY5500_PowerLineFrequency : JY5500.h
  • JY5500_PXI_Trig0 : JY5500.h
  • JY5500_PXI_Trig0_IN : JY5500.h
  • JY5500_PXI_Trig1 : JY5500.h
  • JY5500_PXI_Trig1_IN : JY5500.h
  • JY5500_PXI_Trig2 : JY5500.h
  • JY5500_PXI_Trig2_IN : JY5500.h
  • JY5500_PXI_Trig3 : JY5500.h
  • JY5500_PXI_Trig3_IN : JY5500.h
  • JY5500_PXI_Trig4 : JY5500.h
  • JY5500_PXI_Trig4_IN : JY5500.h
  • JY5500_PXI_Trig5 : JY5500.h
  • JY5500_PXI_Trig5_IN : JY5500.h
  • JY5500_PXI_Trig6 : JY5500.h
  • JY5500_PXI_Trig6_IN : JY5500.h
  • JY5500_PXI_Trig7 : JY5500.h
  • JY5500_PXI_Trig7_IN : JY5500.h
  • JY5500_PXIe_Clk100 : JY5500.h
  • JY5500_PXITrig0_OUT : JY5500.h
  • JY5500_PXITrig1_OUT : JY5500.h
  • JY5500_PXITrig2_OUT : JY5500.h
  • JY5500_PXITrig3_OUT : JY5500.h
  • JY5500_PXITrig4_OUT : JY5500.h
  • JY5500_PXITrig5_OUT : JY5500.h
  • JY5500_PXITrig6_OUT : JY5500.h
  • JY5500_PXITrig7_OUT : JY5500.h
  • JY5500_ReferenceClock : JY5500.h
  • JY5500_ReferenceTrigger : JY5500.h
  • JY5500_Rising : JY5500.h
  • JY5500_RisingSlope : JY5500.h
  • JY5500_SetDeviceReferenceClock() : JY5500.h
  • JY5500_SetDeviceStatusLed() : JY5500.h
  • JY5500_SetPFIFilter() : JY5500.h
  • JY5500_Signal_Destination : JY5500.h
  • JY5500_Signal_Source : JY5500.h
  • JY5500_SignalRouting() : JY5500.h
  • JY5500_StartTrigger : JY5500.h
  • JY5500_TimeBase_200M : JY5500.h
  • JY5500_TriggerMode : JY5500.h


5500 C++ Programming Manual: File Members

- j -

  • JY5500_AI_SampleMode : JY5500.h
  • JY5500_AI_Terminal : JY5500.h
  • JY5500_AI_TriggerType : JY5500.h
  • JY5500_AnalogTriggerEdge : JY5500.h
  • JY5500_AnalogTriggerSource : JY5500.h
  • JY5500_AnalogWindowCondition : JY5500.h
  • JY5500_AO_TriggerType : JY5500.h
  • JY5500_AO_UpdateMode : JY5500.h
  • JY5500_CI_CounterEventSignalIdleState : JY5500.h
  • JY5500_CI_MeasureType : JY5500.h
  • JY5500_CI_SampleClock : JY5500.h
  • JY5500_CI_SampleMode : JY5500.h
  • JY5500_CIO_TriggerType : JY5500.h
  • JY5500_ClockSource : JY5500.h
  • JY5500_CO_IdleState : JY5500.h
  • JY5500_CO_OUTMode : JY5500.h
  • JY5500_CountDirection : JY5500.h
  • JY5500_CountTimeBase : JY5500.h
  • JY5500_DI_SampleMode : JY5500.h
  • JY5500_DI_TriggerType : JY5500.h
  • JY5500_DigitalTriggerEdge : JY5500.h
  • JY5500_DigitalTriggerSource : JY5500.h
  • JY5500_DO_TriggerType : JY5500.h
  • JY5500_DO_UpdateMode : JY5500.h
  • JY5500_ExternalClockTerminal : JY5500.h
  • JY5500_LevelState : JY5500.h
  • JY5500_PowerLineFrequency : JY5500.h
  • JY5500_ReferenceClock : JY5500.h
  • JY5500_Signal_Destination : JY5500.h
  • JY5500_Signal_Source : JY5500.h
  • JY5500_TriggerMode : JY5500.h


5500 C++ Programming Manual: File Members

- j -

  • JY5500_50_Hz : JY5500.h
  • JY5500_60_Hz : JY5500.h
  • JY5500_AI_Analog : JY5500.h
  • JY5500_AI_Continuous : JY5500.h
  • JY5500_AI_Diff : JY5500.h
  • JY5500_AI_Digital : JY5500.h
  • JY5500_AI_Finite : JY5500.h
  • JY5500_AI_Immediately : JY5500.h
  • JY5500_AI_NRSE : JY5500.h
  • JY5500_AI_ReferenceTrig : JY5500.h
  • JY5500_AI_RSE : JY5500.h
  • JY5500_AI_SampleClock : JY5500.h
  • JY5500_AI_Single : JY5500.h
  • JY5500_AI_Soft : JY5500.h
  • JY5500_AI_StartTrig : JY5500.h
  • JY5500_AO_ContinuousNoWrapping : JY5500.h
  • JY5500_AO_ContinuousWrapping : JY5500.h
  • JY5500_AO_Digital : JY5500.h
  • JY5500_AO_Finite : JY5500.h
  • JY5500_AO_Immediately : JY5500.h
  • JY5500_AO_SampleClock : JY5500.h
  • JY5500_AO_Single : JY5500.h
  • JY5500_AO_Soft : JY5500.h
  • JY5500_AO_StartTrig : JY5500.h
  • JY5500_Channel_0 : JY5500.h
  • JY5500_Channel_1 : JY5500.h
  • JY5500_Channel_10 : JY5500.h
  • JY5500_Channel_11 : JY5500.h
  • JY5500_Channel_12 : JY5500.h
  • JY5500_Channel_13 : JY5500.h
  • JY5500_Channel_14 : JY5500.h
  • JY5500_Channel_15 : JY5500.h
  • JY5500_Channel_16 : JY5500.h
  • JY5500_Channel_17 : JY5500.h
  • JY5500_Channel_18 : JY5500.h
  • JY5500_Channel_19 : JY5500.h
  • JY5500_Channel_2 : JY5500.h
  • JY5500_Channel_20 : JY5500.h
  • JY5500_Channel_21 : JY5500.h
  • JY5500_Channel_22 : JY5500.h
  • JY5500_Channel_23 : JY5500.h
  • JY5500_Channel_24 : JY5500.h
  • JY5500_Channel_25 : JY5500.h
  • JY5500_Channel_26 : JY5500.h
  • JY5500_Channel_27 : JY5500.h
  • JY5500_Channel_28 : JY5500.h
  • JY5500_Channel_29 : JY5500.h
  • JY5500_Channel_3 : JY5500.h
  • JY5500_Channel_30 : JY5500.h
  • JY5500_Channel_31 : JY5500.h
  • JY5500_Channel_4 : JY5500.h
  • JY5500_Channel_5 : JY5500.h
  • JY5500_Channel_6 : JY5500.h
  • JY5500_Channel_7 : JY5500.h
  • JY5500_Channel_8 : JY5500.h
  • JY5500_Channel_9 : JY5500.h
  • JY5500_CI_0_SampleClock : JY5500.h
  • JY5500_CI_0_StartTrig : JY5500.h
  • JY5500_CI_1_SampleClock : JY5500.h
  • JY5500_CI_1_StartTrig : JY5500.h
  • JY5500_CI_2_SampleClock : JY5500.h
  • JY5500_CI_2_StartTrig : JY5500.h
  • JY5500_CI_3_SampleClock : JY5500.h
  • JY5500_CI_3_StartTrig : JY5500.h
  • JY5500_CI_Continuous : JY5500.h
  • JY5500_CI_Count_Down : JY5500.h
  • JY5500_CI_Count_External : JY5500.h
  • JY5500_CI_Count_Up : JY5500.h
  • JY5500_CI_CounterEventSignalIdleState_High : JY5500.h
  • JY5500_CI_CounterEventSignalIdleState_Low : JY5500.h
  • JY5500_CI_EdgeCount : JY5500.h
  • JY5500_CI_EncoderTwoPulse : JY5500.h
  • JY5500_CI_EncoderX1 : JY5500.h
  • JY5500_CI_EncoderX2 : JY5500.h
  • JY5500_CI_EncoderX4 : JY5500.h
  • JY5500_CI_ExternalClock : JY5500.h
  • JY5500_CI_Finite : JY5500.h
  • JY5500_CI_ImplicitClock : JY5500.h
  • JY5500_CI_InternalClock : JY5500.h
  • JY5500_CI_Measure_EdgeSeparation : JY5500.h
  • JY5500_CI_Measure_FrequencyOrPeriod : JY5500.h
  • JY5500_CI_Measure_PulseWidth : JY5500.h
  • JY5500_CI_Single : JY5500.h
  • JY5500_CIO_Digital : JY5500.h
  • JY5500_CIO_Immediately : JY5500.h
  • JY5500_CIO_Soft : JY5500.h
  • JY5500_CO_0_Output : JY5500.h
  • JY5500_CO_0_StartTrig : JY5500.h
  • JY5500_CO_1_Output : JY5500.h
  • JY5500_CO_1_StartTrig : JY5500.h
  • JY5500_CO_2_Output : JY5500.h
  • JY5500_CO_2_StartTrig : JY5500.h
  • JY5500_CO_3_Output : JY5500.h
  • JY5500_CO_3_StartTrig : JY5500.h
  • JY5500_CO_ContinuousNoWrapping : JY5500.h
  • JY5500_CO_ContinuousWrapping : JY5500.h
  • JY5500_CO_Finite : JY5500.h
  • JY5500_CO_HighLevel : JY5500.h
  • JY5500_CO_LowLevel : JY5500.h
  • JY5500_CO_Single : JY5500.h
  • JY5500_DI_Continuous : JY5500.h
  • JY5500_DI_Digital : JY5500.h
  • JY5500_DI_Finite : JY5500.h
  • JY5500_DI_Immediately : JY5500.h
  • JY5500_DI_ReferenceTrig : JY5500.h
  • JY5500_DI_SampleClock : JY5500.h
  • JY5500_DI_Single : JY5500.h
  • JY5500_DI_Soft : JY5500.h
  • JY5500_DI_StartTrig : JY5500.h
  • JY5500_DO_ContinuousNoWrapping : JY5500.h
  • JY5500_DO_ContinuousWrapping : JY5500.h
  • JY5500_DO_Digital : JY5500.h
  • JY5500_DO_Finite : JY5500.h
  • JY5500_DO_Immediately : JY5500.h
  • JY5500_DO_SampleClock : JY5500.h
  • JY5500_DO_Single : JY5500.h
  • JY5500_DO_Soft : JY5500.h
  • JY5500_DO_StartTrig : JY5500.h
  • JY5500_ECLK : JY5500.h
  • JY5500_Entering : JY5500.h
  • JY5500_ExternalClock : JY5500.h
  • JY5500_Falling : JY5500.h
  • JY5500_FallingSlope : JY5500.h
  • JY5500_HighLevel : JY5500.h
  • JY5500_Inter_AI_ReferenceTrig : JY5500.h
  • JY5500_Inter_AI_SampleClock : JY5500.h
  • JY5500_Inter_AI_StartTrig : JY5500.h
  • JY5500_Inter_AO_SampleClock : JY5500.h
  • JY5500_Inter_AO_StartTrig : JY5500.h
  • JY5500_Inter_CI0_SampleClock : JY5500.h
  • JY5500_Inter_CI1_SampleClock : JY5500.h
  • JY5500_Inter_CI2_SampleClock : JY5500.h
  • JY5500_Inter_CI3_SampleClock : JY5500.h
  • JY5500_Inter_CI_0_StartTrig : JY5500.h
  • JY5500_Inter_CI_1_StartTrig : JY5500.h
  • JY5500_Inter_CI_2_StartTrig : JY5500.h
  • JY5500_Inter_CI_3_StartTrig : JY5500.h
  • JY5500_Inter_CO_0_Output : JY5500.h
  • JY5500_Inter_CO_0_Output_Trig : JY5500.h
  • JY5500_Inter_CO_0_StartTrig : JY5500.h
  • JY5500_Inter_CO_1_Output : JY5500.h
  • JY5500_Inter_CO_1_Output_Trig : JY5500.h
  • JY5500_Inter_CO_1_StartTrig : JY5500.h
  • JY5500_Inter_CO_2_Output : JY5500.h
  • JY5500_Inter_CO_2_Output_Trig : JY5500.h
  • JY5500_Inter_CO_2_StartTrig : JY5500.h
  • JY5500_Inter_CO_3_Output : JY5500.h
  • JY5500_Inter_CO_3_Output_Trig : JY5500.h
  • JY5500_Inter_CO_3_StartTrig : JY5500.h
  • JY5500_Inter_DI_ReferenceTrig : JY5500.h
  • JY5500_Inter_DI_SampleClock : JY5500.h
  • JY5500_Inter_DI_StartTrig : JY5500.h
  • JY5500_Inter_DO_SampleClock : JY5500.h
  • JY5500_Inter_DO_StartTrig : JY5500.h
  • JY5500_Internal : JY5500.h
  • JY5500_InternalClock : JY5500.h
  • JY5500_Leaving : JY5500.h
  • JY5500_LowLevel : JY5500.h
  • JY5500_PFI0 : JY5500.h
  • JY5500_PFI0_OUT : JY5500.h
  • JY5500_PFI1 : JY5500.h
  • JY5500_PFI10 : JY5500.h
  • JY5500_PFI10_OUT : JY5500.h
  • JY5500_PFI11 : JY5500.h
  • JY5500_PFI11_OUT : JY5500.h
  • JY5500_PFI12 : JY5500.h
  • JY5500_PFI12_OUT : JY5500.h
  • JY5500_PFI13 : JY5500.h
  • JY5500_PFI13_OUT : JY5500.h
  • JY5500_PFI14 : JY5500.h
  • JY5500_PFI14_OUT : JY5500.h
  • JY5500_PFI15 : JY5500.h
  • JY5500_PFI15_OUT : JY5500.h
  • JY5500_PFI1_OUT : JY5500.h
  • JY5500_PFI2 : JY5500.h
  • JY5500_PFI2_OUT : JY5500.h
  • JY5500_PFI3 : JY5500.h
  • JY5500_PFI3_OUT : JY5500.h
  • JY5500_PFI4 : JY5500.h
  • JY5500_PFI4_OUT : JY5500.h
  • JY5500_PFI5 : JY5500.h
  • JY5500_PFI5_OUT : JY5500.h
  • JY5500_PFI6 : JY5500.h
  • JY5500_PFI6_OUT : JY5500.h
  • JY5500_PFI7 : JY5500.h
  • JY5500_PFI7_OUT : JY5500.h
  • JY5500_PFI8 : JY5500.h
  • JY5500_PFI8_OUT : JY5500.h
  • JY5500_PFI9 : JY5500.h
  • JY5500_PFI9_OUT : JY5500.h
  • JY5500_PXI_Trig0 : JY5500.h
  • JY5500_PXI_Trig0_IN : JY5500.h
  • JY5500_PXI_Trig1 : JY5500.h
  • JY5500_PXI_Trig1_IN : JY5500.h
  • JY5500_PXI_Trig2 : JY5500.h
  • JY5500_PXI_Trig2_IN : JY5500.h
  • JY5500_PXI_Trig3 : JY5500.h
  • JY5500_PXI_Trig3_IN : JY5500.h
  • JY5500_PXI_Trig4 : JY5500.h
  • JY5500_PXI_Trig4_IN : JY5500.h
  • JY5500_PXI_Trig5 : JY5500.h
  • JY5500_PXI_Trig5_IN : JY5500.h
  • JY5500_PXI_Trig6 : JY5500.h
  • JY5500_PXI_Trig6_IN : JY5500.h
  • JY5500_PXI_Trig7 : JY5500.h
  • JY5500_PXI_Trig7_IN : JY5500.h
  • JY5500_PXIe_Clk100 : JY5500.h
  • JY5500_PXITrig0_OUT : JY5500.h
  • JY5500_PXITrig1_OUT : JY5500.h
  • JY5500_PXITrig2_OUT : JY5500.h
  • JY5500_PXITrig3_OUT : JY5500.h
  • JY5500_PXITrig4_OUT : JY5500.h
  • JY5500_PXITrig5_OUT : JY5500.h
  • JY5500_PXITrig6_OUT : JY5500.h
  • JY5500_PXITrig7_OUT : JY5500.h
  • JY5500_ReferenceTrigger : JY5500.h
  • JY5500_Rising : JY5500.h
  • JY5500_RisingSlope : JY5500.h
  • JY5500_StartTrigger : JY5500.h
  • JY5500_TimeBase_200M : JY5500.h


5500 C++ Programming Manual: File Members

- j -

  • JY5500_AI_CheckBufferStatus() : JY5500.h
  • JY5500_AI_CheckBufferStatusEx() : JY5500.h
  • JY5500_AI_EnableChannel() : JY5500.h
  • JY5500_AI_ReadData() : JY5500.h
  • JY5500_AI_ReadRawData() : JY5500.h
  • JY5500_AI_ReadRawSinglePoint() : JY5500.h
  • JY5500_AI_ReadSinglePoint() : JY5500.h
  • JY5500_AI_SendSoftTrigger() : JY5500.h
  • JY5500_AI_SetAnalogEdgeReferenceTrigger() : JY5500.h
  • JY5500_AI_SetAnalogEdgeStartTrigger() : JY5500.h
  • JY5500_AI_SetAnalogHysteresisReferenceTrigger() : JY5500.h
  • JY5500_AI_SetAnalogHysteresisStartTrigger() : JY5500.h
  • JY5500_AI_SetAnalogWindowReferenceTrigger() : JY5500.h
  • JY5500_AI_SetAnalogWindowStartTrigger() : JY5500.h
  • JY5500_AI_SetConvertRate() : JY5500.h
  • JY5500_AI_SetDigitalReferenceTrigger() : JY5500.h
  • JY5500_AI_SetDigitalStartTrigger() : JY5500.h
  • JY5500_AI_SetDSMode() : JY5500.h
  • JY5500_AI_SetMode() : JY5500.h
  • JY5500_AI_SetPreTriggerSamples() : JY5500.h
  • JY5500_AI_SetReferenceTriggerType() : JY5500.h
  • JY5500_AI_SetReTriggerCount() : JY5500.h
  • JY5500_AI_SetSampleClock() : JY5500.h
  • JY5500_AI_SetSampleRate() : JY5500.h
  • JY5500_AI_SetSamplesToAcquire() : JY5500.h
  • JY5500_AI_SetStartTriggerType() : JY5500.h
  • JY5500_AI_Start() : JY5500.h
  • JY5500_AI_Stop() : JY5500.h
  • JY5500_AI_WaitUntilDone() : JY5500.h
  • JY5500_AO_CheckBufferStatus() : JY5500.h
  • JY5500_AO_CheckBufferStatusEx() : JY5500.h
  • JY5500_AO_EnableChannel() : JY5500.h
  • JY5500_AO_SendSoftTrigger() : JY5500.h
  • JY5500_AO_SetDigitalStartTrigger() : JY5500.h
  • JY5500_AO_SetMode() : JY5500.h
  • JY5500_AO_SetSampleClock() : JY5500.h
  • JY5500_AO_SetSamplesToUpdate() : JY5500.h
  • JY5500_AO_SetStartTriggerType() : JY5500.h
  • JY5500_AO_SetUpdateRate() : JY5500.h
  • JY5500_AO_Start() : JY5500.h
  • JY5500_AO_Stop() : JY5500.h
  • JY5500_AO_WaitUntilDone() : JY5500.h
  • JY5500_AO_WriteData() : JY5500.h
  • JY5500_AO_WriteRawData() : JY5500.h
  • JY5500_AO_WriteRawSinglePoint() : JY5500.h
  • JY5500_AO_WriteSinglePoint() : JY5500.h
  • JY5500_CI_CheckBufferStatus() : JY5500.h
  • JY5500_CI_CheckBufferStatusEx() : JY5500.h
  • JY5500_CI_EnableChannel() : JY5500.h
  • JY5500_CI_ReadCountValues() : JY5500.h
  • JY5500_CI_ReadMeasureValues() : JY5500.h
  • JY5500_CI_ReadSingleCountValue() : JY5500.h
  • JY5500_CI_ReadSingleMeasureValue() : JY5500.h
  • JY5500_CI_SendSoftTrigger() : JY5500.h
  • JY5500_CI_SetCounterParament() : JY5500.h
  • JY5500_CI_SetCounterType() : JY5500.h
  • JY5500_CI_SetDigitalStartTrigger() : JY5500.h
  • JY5500_CI_SetEdgeCountEvent() : JY5500.h
  • JY5500_CI_SetMode() : JY5500.h
  • JY5500_CI_SetPauseTriggerLevel() : JY5500.h
  • JY5500_CI_SetSampleClock() : JY5500.h
  • JY5500_CI_SetSamplesToAcquire() : JY5500.h
  • JY5500_CI_SetSignalReverse() : JY5500.h
  • JY5500_CI_SetStartTriggerType() : JY5500.h
  • JY5500_CI_SetTimeBase() : JY5500.h
  • JY5500_CI_SetZReloadEnabled() : JY5500.h
  • JY5500_CI_Start() : JY5500.h
  • JY5500_CI_Stop() : JY5500.h
  • JY5500_Close() : JY5500.h
  • JY5500_CO_CheckBufferStatus() : JY5500.h
  • JY5500_CO_CheckBufferStatusEx() : JY5500.h
  • JY5500_CO_CheckCounterStatus() : JY5500.h
  • JY5500_CO_EnableChannel() : JY5500.h
  • JY5500_CO_SendSoftTrigger() : JY5500.h
  • JY5500_CO_SetCounterParament() : JY5500.h
  • JY5500_CO_SetDigitalStartTrigger() : JY5500.h
  • JY5500_CO_SetFrequency() : JY5500.h
  • JY5500_CO_SetFrequencyOnFly() : JY5500.h
  • JY5500_CO_SetMode() : JY5500.h
  • JY5500_CO_SetSamplesToUpdate() : JY5500.h
  • JY5500_CO_SetStartTriggerType() : JY5500.h
  • JY5500_CO_SetTimeBase() : JY5500.h
  • JY5500_CO_Start() : JY5500.h
  • JY5500_CO_Stop() : JY5500.h
  • JY5500_CO_WaitUntilDone() : JY5500.h
  • JY5500_CO_WriteData() : JY5500.h
  • JY5500_DI_AddLines() : JY5500.h
  • JY5500_DI_CheckBufferStatus() : JY5500.h
  • JY5500_DI_CheckBufferStatusEx() : JY5500.h
  • JY5500_DI_ReadData() : JY5500.h
  • JY5500_DI_ReadSinglePoint() : JY5500.h
  • JY5500_DI_ReadSinglePoint_U64() : JY5500.h
  • JY5500_DI_ReadSinglePoint_U8() : JY5500.h
  • JY5500_DI_SendSoftTrigger() : JY5500.h
  • JY5500_DI_SetDigitalReferenceTrigger() : JY5500.h
  • JY5500_DI_SetDigitalStartTrigger() : JY5500.h
  • JY5500_DI_SetMode() : JY5500.h
  • JY5500_DI_SetPreTriggerSamples() : JY5500.h
  • JY5500_DI_SetReferenceTriggerType() : JY5500.h
  • JY5500_DI_SetSampleClock() : JY5500.h
  • JY5500_DI_SetSampleRate() : JY5500.h
  • JY5500_DI_SetSamplesToAcquire() : JY5500.h
  • JY5500_DI_SetStartTriggerType() : JY5500.h
  • JY5500_DI_Start() : JY5500.h
  • JY5500_DI_Stop() : JY5500.h
  • JY5500_DI_WaitUntilDone() : JY5500.h
  • JY5500_DisableAICalibration() : JY5500.h
  • JY5500_DisableAOCalibration() : JY5500.h
  • JY5500_DisconnectSignalRouting() : JY5500.h
  • JY5500_DO_AddLines() : JY5500.h
  • JY5500_DO_CheckBufferStatus() : JY5500.h
  • JY5500_DO_CheckBufferStatusEx() : JY5500.h
  • JY5500_DO_SendSoftTrigger() : JY5500.h
  • JY5500_DO_SetDigitalStartTrigger() : JY5500.h
  • JY5500_DO_SetMode() : JY5500.h
  • JY5500_DO_SetSampleClock() : JY5500.h
  • JY5500_DO_SetSamplesToUpdate() : JY5500.h
  • JY5500_DO_SetStartTriggerType() : JY5500.h
  • JY5500_DO_SetUpdateRate() : JY5500.h
  • JY5500_DO_Start() : JY5500.h
  • JY5500_DO_Stop() : JY5500.h
  • JY5500_DO_WaitUntilDone() : JY5500.h
  • JY5500_DO_WriteData() : JY5500.h
  • JY5500_DO_WriteSinglePoint() : JY5500.h
  • JY5500_DO_WriteSinglePoint_U64() : JY5500.h
  • JY5500_DO_WriteSinglePoint_U8() : JY5500.h
  • JY5500_GetDeviceFPGATemperature() : JY5500.h
  • JY5500_GetDeviceID() : JY5500.h
  • JY5500_GetDeviceSerialNumber() : JY5500.h
  • JY5500_GetDeviceTemperature() : JY5500.h
  • JY5500_Open() : JY5500.h
  • JY5500_OpenByName() : JY5500.h
  • JY5500_SetDeviceReferenceClock() : JY5500.h
  • JY5500_SetDeviceStatusLed() : JY5500.h
  • JY5500_SetPFIFilter() : JY5500.h
  • JY5500_SignalRouting() : JY5500.h


5500 C++ Programming Manual: File Members

  • JY5500_DeviceHandle : JY5500.h


5500 C++ Programming Manual: Main Page

5500 C++ Programming Manual Documentation